Something strange sometimes happens when I'm working on my 2016 MBP 13-inch w/ Touch Bar (Mac OS 10.13.4). I don't know exactly why, but occasionally certain gestures (i.e. pinch to zoom in and zoom out, force touch over a word to open the dictionary) simply stop functioning until I lock and unlock the laptop. Other gestures (mission control, move across desktops) keep working. This happens to all the apps I try to use (Safari, Word, Pages, Ulysses, Mind Node and so on). I can still use keyboard shortcuts to perform those actions.

As I said, the only solution I could find is to lock and unlock the laptop or just reboot it, but I would like to know if there is a better, permanent fix to this issue.

  • This happens when the driver for the touchpad is stopped for some reason. Try to update to the latest system update.
    – SEJU
    May 4, 2018 at 13:43
  • My Mac OS is already updated to the latest stable version available (High Sierra 10.13.4)
    – Noorhain
    May 7, 2018 at 18:48
  • I had once a problem with the trackpad. It stopped to work, the force actuator which created the haptic feedback stopped working and I had to restart to make it work. This happened once or maybe twice in two years. I have a 15” 2016 MBP. I guess it is a driver issue.
    – SEJU
    May 7, 2018 at 18:53
  • Found this at Apple forum: discussions.apple.com/thread/7404046
    – SEJU
    May 7, 2018 at 18:55

2 Answers 2


Sometimes my touchpad getting mad, click force is strange, sound is also strange and force touch isn't working mostly, till until restart. It hardly seems like a software problem, so whenever you restart everything works fine.

The problem occurred much less times after i did a following things:

  1. Clear NVRAM
  2. Install every available Software Updates
  3. Also make sure to clean your touch pad and it's borders, sometimes it can lead to an issue

Also, most of the time that problem occurs after sleep/hibernation, so most likely it is software problem.


I had a similar issue where three-finger-swipe gestures stopped working. Either deactivating and reactivating these gestures in the system settings or putting the Mac to sleep solved that problem.

It turned out that the window manager "Magnet" caused the issue for me. When I quit Magnet, the problem doesn't occur anymore (Credits to minimalmo at Reddit).

Edit: I asked the author of "Magnet" if this issue could be fixed, but never received a response. I tried "BetterSnapTool" as an alternative, which seems to work well.

  • I happen to use Magnet as well. It might be involved in my issues, which by the way still occurring occasionally (now in Mac Os 10.14).
    – Noorhain
    Nov 1, 2018 at 15:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .