I recently got an iPhone 4. At home, it connected to our wifi and worked perfectly. Now I am at school. My iPhone is now connected to the wifi here, it says that it is connected and has strong wifi signal. However apps that require internet like email, Facebook app, and online games (like words with friends, etc) load and stall showing "updating". All apps are unable to actually update. It shows it is loading for forever.

What can I do to fix this?

  • ios uses several ports that most firewalls block. sorry i can't be more specific at the moment, but I had to get my sysadmin to unblock about 4 ports for stuff like facebook, google voice and facetime to work. I found the list of ports online, but I can't remember what they are, sorry
    – user14284
    Nov 29, 2011 at 2:39
  • Do your school wifi require you to log in before you get full access? Nov 29, 2011 at 10:20
  • Which app is updating? Can you browse the web using Safari as soon as you join the network to see if a better error message can be seen?
    – bmike
    Jul 3, 2012 at 15:38

6 Answers 6


Go to Settings, then Network. Select your network. Click the accessory button to see the network settings.

If you don't have an IP address, scroll down and tap "Renew Lease".

If you have an IP address that is a 168... number, it means you are not getting an IP address from the school's server. You'll need to contact their sysadmins.

Hope this helps.


Your iPhone and iOS in general simply uses DHCP to request an IP address and routing information on every network it joins.

In the case where the device works on other networks, it's extremely rare for the phone to then misbehave on one specific network.

Have you gone through the troubleshooting steps (see the link below)? It's good form to try these, but you may need to contact someone who knows if your network uses proxy servers, filtering or authentication to prevent new devices from using the network to access the internet. Just joining a network means your phone has connected to the radio - not that you have a clear path to the internet (without ports being blocked) or even a viable routable IP address to use the local network.


Try using Safari and see if it shows some sort of login page for the school's network. Then see if you can browse your school's internal web site. If so, maybe the school is running some sort of firewall.


It's very possible that your school requires a proxy server for internet access - you can confirm this by checking a machine that has internet access.

On your phone, you can configure the proxy settings in Settings -> Wi-Fi Networks -> Your network -> HTTP Proxy.


I had a problem last night and today where ALL my iOS devices would connect to one of my Airport Extremes (2 that are around 405 years old, a couple generations, one running 2.4ghz and one 5ghz, and one of the new tall ones with both 2.4ghz and 5ghz networks), did not matter which one, but would NOT show the WiFi fan symbol and would not connect to the internet, even when showing connected with a check in the iOS Settings app. This was multiple phones and iPads. The Macs in the house had no issues. I ran the Airport Utility on my Mac but did not see anything wrong with any of them. I ended up unplugging them one at a time and letting them reboot. Now all the iOS devices can attach to any of the 4 wireless networks created by the devices and get to the internet. So try physically rebooting the router/airport device.


This is precisely what happens when the DNS server IP address configured in the wireless router is bad. (We had our ISP simply stop using some addresses for DNS!) iOS devices typically configure their wifi access by default to defer DNS to the router. If the router has bad addresses, the iOS device (or Apple TV) can't connect via wifi to the internet - it can't resolve addresses.

A Mac, on the other hand, usually has a list of prospective DNS server IP addresses, used to resolve addresses BEFORE the router. Thus, if any 1 of the addresses in their DNS list is operational, the Mac can make an internet connection despite the router.

  • If one of the DNS server addresses configured in the DHCP server is bad, shouldn't it at least work some of the time?
    – nohillside
    Nov 1, 2014 at 21:00
  • Yes, it did. I'm using a new Time Capsule that has room in configuration for 2 DNS addresses... both of which were supplied by my ISP. Unknown to me, they abandoned one of them (and someone registered the IP for something else) some months ago. Problem occurred when they abandoned the 2nd (and only remaining) one on Halloween. Embarq bought Sprint customers, CenturyLink bought Embarq customers, legacy DNS servers along the way disabled without notice.
    – JBJr
    Nov 3, 2014 at 14:23
  • I understand that it was like this for you, but if I understand the question correctly it never works/worked there.
    – nohillside
    Nov 3, 2014 at 15:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .