0

I've upgraded my iPhone 3GS to the new iPhone 4S. I want to give my old 3GS to my daughter to use as an "iPod touch". We've upgraded the 3GS to iOS 5 and attached it to iCloud with her own separate account.

I'd like for the 3GS to be able to text me on my 4S - yet it is the same phone number the 3GS used to be, it doesn't seem to work.

I've also tried to text from the 3GS to another iPod touch we have (new, 4th gen). Yet it just texts to an email address. It doesn't appear as a text/iMessage/SMS.

Is there a setting I'm missing? I'd really like it to show as a text and not an email.

1

Cellular SMS requires an activated SIM card.

When you upgraded to a 4s, the phone company probably deactivated the SIM in your 3GS, so it can't be used for SMS without another valid SIM card.

0

When a iDevice wants to use iMessage it needs to be registered with an AppleID, and an email address (can be something else than the AppleID) or a phone number in the case of an iPhone. You can change this setting here:

Settings > Messages > Receive At

You always need one address or phone number in there. To remove one address, select it from the list and then click Remove.

But as far as I know, i don't think an iPhone can receive iMessage without a phone number… that could prove difficult to circumvent. Let us know if you have any result. Perhaps with the old SIM inserted in the iPhone you can remove the phone number from the list...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .