6

I want to stop this prompt:

enter image description here

Normally I’d encourage people to keep their system / app up-to-date, but there is only one word that can describe what Microsoft had done in Office for Mac: catastrophe.

Their Apr 2018 update destroyed the ability to display / assign Asian font correctly. Prior to the update, I can view & set Asian font using the Asian name of a font family (e.g. "細明體" instead of "PMingLiU"). But after update all fonts are displayed using English font family name. I can stil use these Asian fonts, but it's no longer be compatible with Windows version.

Besides, the performance is severely declined after update: the text input curser can’t even catch up with my typing speed.

I've managed to revert to older version via Time Machine backup. This is not the first time that Office update ruined everything so I'd always make backup before applying for update. Now I just want to stop this annoying prompt.

2
  • Word behaves differently based on license. I'll assume you have O365 subscription - check in the about window for your Word in case you have a license that's different...
    – bmike
    May 4 '18 at 2:19
  • @bmike: I don't have 365 subscription. This is the 2016 standalone version that I purchased directly from Microsoft's office online shop.
    – RichardLiu
    May 4 '18 at 3:20
8

Remove the "/Library/Application Support/Microsoft/MAU2.0" folder, which to place the Microsoft Auto Update (MAU) program.

Update: I found ms-office applicaiton would create the MAU2.0 and Microsoft AutoUpdate.app automatically after some days. You can create a blank file named MAU2.0 in the "/Library/Application Support/Microsoft" folder.

sudo touch "/Library/Application Support/Microsoft/MAU2.0"

enter image description here

2
  • 1
    What does this do? Are there any side effects (things which get lost/reset)?
    – nohillside
    Mar 20 '19 at 16:55
  • It's only for Microsoft AutoUpdate.app, just remove it if you don't want to display the updating prompt. @nohillside
    – jet ma
    Sep 10 '19 at 2:38
2

If you get Office from the Mac App Store, that handles all updates. You can delete your old version of the app and get It from Apple now. You do need an office 365 license, so if you have volume license or an older type license the App Store might not work for you for free.

If for some reason you are getting the app elsewhere, the usual way is to open updates from the word help menu and enable manual update checks.

enter image description here

The Microsoft Auto Update program (MAU) is undergoing pretty rapid and dramatic improvements including the ability to set preferences to control updates as well as command line updates. Check this site and link for details as well as links to old versions of apps if you decide you need to roll back an update or manually update part of Office 2016 and not Word.

6
  • 1
    I did, and that's exactly the reason that Word keeps popping up this prompt every time when I open a document. Just want to know is there anyway to stop this prompt, without installing that disastrous update.
    – RichardLiu
    May 4 '18 at 3:18
  • I’ll dig into suppressing the nag. What exactly does your license say - is it a code in the about window or “volume license” @RichardLiu
    – bmike
    May 4 '18 at 3:55
  • Microsoft® Word for Mac, Version 15.41 (171205), Product ID: 02985-010-000001, License: Retail License, Device ID: D09B8424-****-****-B3D2-CA088C5668E6, © 2017 Microsoft, All rights reserved.
    – RichardLiu
    May 4 '18 at 6:24
  • That's all what listed in the "About" dialog. I censored part of the Device ID.
    – RichardLiu
    May 4 '18 at 6:27
  • In case you're questioning me for using pirated version: I bought this from office.com website, at Sep 22 2016, Purchase item name: "Mac 版 Office 家用版 2016" (Office 2016 Home edition for Mac), price: NT$ 4562 (~US$154), purchase ID: 16856557758, payment method: PayPal.
    – RichardLiu
    May 4 '18 at 6:37
2

The most elegant way is to:

  1. Remove com.microsoft.update.agent.plist from /Library/LaunchAgents folder.

  2. Disable the accessibility to the updater with

    sudo chmod 500 /Library/Application\ Support/Microsoft/MAU2.0
    

If you just do step 2 and skip step one you might run into UserEventAgent Process not being able to execute step 1 properly when booting the computer and this leading to high CPU load for hours.

This will disable the Microsoft Office Update mechanism and also remove the update-message within the Office Applications. It also removes the "Search for Updates" drop down in the menu "Help" within the Office Applications.

When you would like to update the system you either undo the steps above or just install/deploy the newest patches. You might have to re-run step 1 and 2 after installing the patches.

(Tested on OSX 10.13.6 with Word/Excel 16.26)

2
  • Nah disable or remove MAU only stops Office from automatically update itself, but it won’t stop that prompts. The behavior is the same even after Office 2019 stand-alone version. All I want is to disable that prompt. That ResetMessage script in other answers is the only viable way to do so, but it’s not a permanent solution.
    – RichardLiu
    Oct 25 '20 at 10:15
  • @RichardLiu, I noticed the message does disappear as soon as it can't reach the updater anymore. I'm not sure if this behaviour is permanent.
    – Olivier
    Oct 26 '20 at 13:38
1

Apparently, this Microsoft employee has published a script to specifically suppress this update prompt.

https://github.com/pbowden-msft/ResetUpdateMessage

I haven't tested it, but the source is there to analyze.

1

This seems to have worked for me - extracted this from the ResetUpdateMessage script on @David William's answer.

Word:

sudo /usr/bin/touch -mt $(date "+%Y%m%d0001") "/Applications/Microsoft Word.app/Contents/Info.plist"

Excel:

sudo /usr/bin/touch -mt $(date "+%Y%m%d0001") "/Applications/Microsoft Excel.app/Contents/Info.plist"

Ppowerpoint:

sudo /usr/bin/touch -mt $(date "+%Y%m%d0001") "/Applications/Microsoft Powerpoint.app/Contents/Info.plist"

One thread suggests the nag is run after 90 days without an update. If so these commands will need running every 90 days. Another thread suggests it is run after missing 3 updates.

To schedule with crontab type sudo crontab -e in Terminal (or iTerm etc), press i, and enter the following to run this every Wednesday at 2pm:

# min  hour  day_of_month  month  day_of_week  command
0 14 * * 3 sudo /usr/bin/touch -mt $(date "+%Y%m%d0001") "/Applications/Microsoft Word.app/Contents/Info.plist"
1 14 * * 3 sudo /usr/bin/touch -mt $(date "+%Y%m%d0001") "/Applications/Microsoft Excel.app/Contents/Info.plist"
2 14 * * 3 sudo /usr/bin/touch -mt $(date "+%Y%m%d0001") "/Applications/Microsoft Powerpoint.app/Contents/Info.plist"

Then press [esc] :wq [Return].

Apple recommends another way to schedule on MacOS. I find crontab simpler. It won't run if your laptop's off though (solutions here) although it only needs to run once every few attempts. If you'd rather only run monthly replace 0 14 * * 3 with 0 14 1 * *, but there's no real reason to.

A checkbox in Preferences would have been nice!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .