1

I tried the answers on the similar previous question but nothing worked. Obviously Apple removed the critical file .AppleSetupDone in the last Security Update. Is there anybody who could help getting my administrator account back?

  • 1
    Welcome to Ask Different. Can you please edit your question to add a reference to the answers you already tried but didn't work? We don't know what you tried and this will prevent us from suggesting those same answers again. – fsb May 3 '18 at 16:04
  • 1
    Rather than say you tried other answers, please show your detailed work. The process of documenting your situation allows someone to help and also keeps the chance of duplicate questions with the same answer from proliferating. – bmike May 5 '18 at 19:07
1

The removal of file .AppleSetupDone to trigger Setup Assistant is still here and fully functional in High Sierra, even in the latest 10.13.5 Beta. You can remove this file either in Single User mode or in Terminal when booted in Recovery Partition.

Another way to restore your admin account is to boot in Recovery Partition, starting Terminal and using the resetpassword command to launch the helper app (see attached screenshot).

enter image description here

  • This is a great answer. Would you consider editing it into the selected answer on apple.stackexchange.com/questions/164331 to let everyone know that answer and the reset tool work on high Sierra? – bmike May 5 '18 at 19:08
  • @bmike I'm afraid I don't know what you mean. There are three answers, which do you suggest I supplant? – boris42 May 5 '18 at 19:43
  • I would tack it on the end of this one, personally. apple.stackexchange.com/a/164332/5472 You could also just make your answer there stand alone. Just suggestions, though. Only do this if it makes sense to you. – bmike May 5 '18 at 20:01
  • @bmike I expanded and submitted apple.stackexchange.com/a/324521/191531 as you suggested. – boris42 May 5 '18 at 20:50

Not the answer you're looking for? Browse other questions tagged .