0

I'm running macOS High Sierra 10.13.4 on VMware on Windows 10 Pro 1803 build 17134.1.

My screen's resolution is 3840x2160 (4K) and I want the macOS to be in resolution 3840x2009.
However. it seems impossible, due to a strange behavior in which when I go to System Preferences → Displays and either click "Default for display" or choose from the resolutions list "3840x2009" - the resolution is changed for like 1 second, and then returning to resolution 1920x1005.
Note: I just reinstalled VMware Tools.

Thanks for the help!

  • Did you try to reboot the VM? – Pratik May 3 '18 at 7:49
  • You can try to set the resolution in "/Library/Preferences/com.apple.windowserver.plist" on macOS and see. – Pratik May 3 '18 at 7:52
  • @PratikaRana If you meant to edit this file, then I don't know where to edit it. – avi12 May 3 '18 at 8:28
  • Execute the following command in Terminal. "sudo defaults delete /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled". Then restart the VM. You should be able to get the required resolution. – Pratik May 3 '18 at 8:36
  • It worked partly. If I don't resize the VMware window - it's okay. Otherwise, if I resize - the resolution scales down. Though if I do return the window to its previous size - it seems to fix it – avi12 May 3 '18 at 10:14
0

You can go Setting -> Display -> Display scaling and turn off check mark "Automatic adjust user interface size in the virtual machine". It works!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .