Yesterday I update MacOS Sierra to MacOS High Sierra than I remove xCode 9.2 after that when I try to install xCode 9.3 from App Store, It gives me below error:

Xcode failed to download, Use the purchase page to try again I tried below solutions.

1. Remove Account and again add it.

2. https://gist.github.com/ferbass/3ecc06a8ae992365bf73

3. Xcode failed to download. Use the Purchases page to try again (But There's no Debug menu in MacOS High Sierra)

4. Try to install xCode with Different account but facing same error.

5. Other Applications are downloadable but facing error only in xCode installation.

below are screenshots

enter image description here

enter image description here

5 Answers 5


I had the same issue and finally got this working, however I'm not sure exactly which step made it work, so I'm posting all of them.

From How to fix / Reset App Store app on Mac OSX - El Capitan:



I didn't have some of those folders, but I did have a couple of extras that looked fishy, so I deleted them too:


Run sudo softwareupdate --clear-catalog [Note: I did this but I don't think it helped]

From http://osxdaily.com/2016/10/08/mac-app-store-temp-cache-folder/ (paraphrasing):

  1. Quit out of the Mac App Store
  2. Open Terminal and run open $TMPDIR../C/com.apple.appstore/
  3. Hit Return and the com.apple.appstore folder will open in the Finder of Mac OS
  4. Delete the contents of this folder

And finally:

  1. Navigate to ~/Applications in Finder and move Xcode to the Trash [Note: This step was necessary for me, but ymmv]
  2. Reboot
  3. Launch App Store. Search for Xcode. Install it fresh.
  • As per softwareupdate --help output, the softwareupdate --clear-catalog step is most certainly useless in that situation, indeed. For the record, there's a /private/var/db/softwareupdate/journal.plist file that lists installed updates. Might be good to know what role it plays. May 21, 2019 at 13:59

You can download Xcode without going to the App Store. You will probably need your Apple ID. Goto this Apple download webpage.


Yesterday, I also got the same error while installing Xcode on my MacBook Pro. I am on macOS High Sierra version 10.13.4. I tried various methods available on various forums and Apple's website but to no avail. I believe most of the proposed solutions are not for High Sierra. I also feared it might be due to some residual file or I messed up somehow since I have already installed/uninstalled Xcode several times.

However, today I got some update for High Sierra and after installing it, I tried installing Xcode again and bingo!! It installed successfully. :-)


Had the same issue. The following steps solved it for me.

  1. Create a new user account and login.
  2. Open App Store and login using your Apple ID.
  3. Start downloading Xcode (It should start the download).
  4. You can pause the download and log back in to your previous user account. Xcode should install smoothly now.

I had the same error message but in my case i was trying to install Xcode 10.1 on a Mac high sierra 10.13.6.

I think what causes this error most times is compatibility issues. I later found out that high sierra 10.13.6 requires max of Xcode 10, i went on to download Xcode 10 and it worked fine for me.

You can find older versions of xcode here https://developer.apple.com/download/more/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .