7

I had an issue with my MacBook Air "Core i5" 1.6 13" (Early 2015) (MacBookAir7,2) and after repeated problems I decided to wipe the computer and give it a clean slate.

I downloaded a copy of Mavericks and Yosemite off the internet and created a bootable external hard drive with an iMac. I've tried both Mavericks and Yosemite but always get the prohibited sign.

I tried cmd + S while booting with the hard drive and it said "This version of Mac OS X is not supported on this platform" for both versions of OS X. The funny thing is I tried the bootable hard drive with the old iMac I have in the house and it booted into the installer just fine.

What can I do to fix this issue?

8

To start with your MacBook Air will not run Mavericks, so you can put that one aside as incompatible.

As for Yosemite, the earliest possible version that will run on your model MacBook Air is actually Mac OS X 10.10.2 (build 14C2043). My guess is that the copy of Yosemite you've downloaded is either 10.10.0, 10.10.1 or a build version of 10.10.2 earlier than 14C2043.

Regardless, your best option is usually to boot into Recovery Mode.

Recovery Mode

You can boot into Recovery Mode and reinstall macOS from there. You will have up to three options:

  • Hold down the commandR keys as soon as you power up to reinstall the latest macOS that was installed on your Mac, without upgrading to a later version
  • Hold down the optioncommandR keys as soon as you power up to upgrade to the latest macOS that is compatible with your Mac
  • Hold down the shiftoptioncommandR keys as soon as you power up to reinstall the macOS that came with your Mac, or the version closest to it that is still available1

1 That third option is a new option only available since 27 March 2017 and requires macOS Sierra 10.12.4.

For more info refer to: About macOS Recovery

IMPORTANT - Your question doesn't specify where you've downloaded the installers from. Please note that if you haven't downloaded them directly from Apple then there is no way for anyone here to confirm the suitability/safety of what you've downloaded.


[UPDATE]

Since you're having problems with Recovery Mode I suggest you reset your Non-Volatile Random-Access Memory (NVRAM).

Resetting the NVRAM

To do this on your MacBook Air, follow the steps below.

NOTE: Before following the steps below, ensure you have no external hardware connected and make sure you use the built-in keyboard.

  1. Fully shut down your machine.
  2. Press the power button and then press the commandoptionPR keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you hear the startup chime for the second time.
  4. Let go of the keys

Once you've reset the NVRAM, power off and try the various Recovery Mode keyboard shortcuts again.

  • Hello thank you for the response, My internal hard drive is completely empty (I.e without an OS) and the recovery mode doesn't work. I don't know if it still should. Also when ever I try using internet recovery, it spits out an error half way and restarts from that same point and then loops and I downloaded 10.10.2 – Dami May 2 '18 at 23:01
  • Your internal drive should have a recovery partition which is separate from the one that macOS is installed on, so unless you've erased that somehow or have a faulty drive, some sort of Recovery should work. In fact, Internet Recovery uses a built-in image to boot from first and then only after the utilities screen appears it'll start downloading data from Apple's servers, so the fact you can start that process indicates you still have the necessary partitions on your drive. I would suggest resetting the NVRAM and trying the various Recovery Mode options again. I'll update my answer. – Monomeeth May 2 '18 at 23:22
  • Okay, thank you for your input, when I get to work tomorrow I'll try that and I will let you know. – Dami May 2 '18 at 23:41
  • Hello I tried doing all that and all it does it boot into a screen with a spinning globe and asking for wifi. I suppose that is internet recovery. – Dami May 4 '18 at 17:08
  • I don't have any access to normal recovery mode. Also I think I forgot to mention I wiped my internal hard drive with disk utils before it stopped not responding to recovery mode requests. So was it possible I wiped my recovery partition ? – Dami May 4 '18 at 17:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .