I have a problem with making bootable USB.

I'm getting this error:

Macintosh:~ **$ sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ High\ Sierra.app
Ready to start.
To continue we need to erase the volume at /Volumes/Untitled.
If you wish to continue type (Y) then press return: y
APFS disks may not be used as bootable install media.

On the same usb drive I had Yosemite, but for some reason I can't make it work with High Sierra. Also tried to erase it in Disk Utility(no errors).

Can somebody help?

  • 2
    When erasing the USB drive, change the Format to Mac OS Extended and try creating the installer again. – Nimesh Neema May 2 '18 at 21:05
  • 1
    @NimeshNeema that's the problem, I did(using disk utility) without errors, then I went back to the terminal and tried to create bootable usb again, but got the same error. Will try to restart macbook. – kironet May 2 '18 at 21:29
  • 1
    What format does Disk Utility say the volume is in? – Gordon Davisson May 2 '18 at 22:06
  • @GordonDavisson I restarted Mac and everything works now. Thanks – kironet May 3 '18 at 9:44

I think the message is quite straightforward: It seems like your USB stick is formatted as APFS and the error message says that you can't.

Reformat the USB Stick using Mac OS Extended instead.


I also faced similar issue. When I verified the disk name I found that my internal disk name was also 'Untitled' as shown in below image.

So I changed USB device name and it worked.

enter image description here


I had the same issue, but solve it using Paragon free software to downgrade to HFS+, as the Disk Utility didn't have to option to erase it to that format.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .