2

Lately my Macbook Pro switches to the "Lock Screen" page out of nowhere while I am working. When I say "while I am working" I want to make clear it's not due to inactivity, I am actually using the computer as it happens.

It does not log me out (none of my windows are closed), it only locks.

I've noticed it happens usually shortly after I've logged in. So for example it's morning, I login start doing things then a few seconds later I'm locked out. I log back in, and again a few seconds later I'm locked out. It happens 2 or 3 times before it quiets down.

macOS High Sierra 10.13.4

  • Did you solved this problem it happens to me too. – Jose Sanchez Palacios Dec 13 '18 at 21:17
  • Are you using any screen sharing / remote desktop features? – amdyes Dec 14 '18 at 3:06
  • It actually stopped happening ... I am not sure exactly when and why – nute Dec 14 '18 at 4:51
1

It is likely that accidentally the lock screen keyboard shortcut, i.e. Control + Command + q is getting invoked.

enter image description here

It could be either you pressing the key sequence unknowingly or, one or two of the keys from the combination is stuck and pressing the third key by chance is invoking the sequence.

To resolve this issue, shut down your MacBook Pro, and repeatedly tap on each of the keys in succession and try to unstuck them. They turn on the MacBook Pro, resume your work and see if the problem goes away.

  • 1
    Interesting theory. I've just tried now to press combinations of 2 keys, no lock out. I find it hard to believe I would accidentally press all 3. Also, what do you make of the fact that it happens at the beginning of a session, and not later? – nute May 2 '18 at 8:36
  • 1
    What I mean is that one or two of the two maybe stuck and pressing the remaining two or one keys invoke the shortcut (while you are trying to invoke some other shortcut, for e.g.). You can use the on-screen keyboard viewer (as discussed in this answer: apple.stackexchange.com/a/40199/279727) to see if the offending keys are pressed. – Nimesh Neema May 2 '18 at 8:45
  • 2
    Check System prefs > Desktop & Screen Saver > Hot Corners. You might have one corner set to sleep. Also check ~/Library/LaunchAgents see if you have any rogue services trying to start up. – sansSpoon May 2 '18 at 23:49
  • Today it happened twice in a row, without me even touching the keyboard. Good idea about the hot corners, but no there are none. I looked at the LaunchAgents, I have just a few, all from known developers, hard to say if one is misbehaving. Although ... one if from my employer (the registration system). – nute May 8 '18 at 6:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .