2

I ran into a really annoying problem yesterday. In a small office of just three workstations (and two more that connect remotely), the computers cannot automatically connect to the fileserver on boot. Instead of using the username/password associated with the shared folders, it automatically connects using the AppleID, which works because the server uses the same AppleID. The server is a Mac mini running High Sierra also.

So let me explain. In the past, sometimes this would happen, where you would click on a shared Mac and it would sometimes try to auto-connect as the same user you are using on the current computer, or using the AppleID. But you click disconnect, then reconnect, and type in the correct username and password. Checking the box to remember the password. Once the volumes are mounted, you save them to the dock, you put them in the "Login Items" folder, and BAM auto-mounting network shares.

But now that does not happen. Now no matter what, it connects to the server using the AppleID. So the shares will be working perfectly. Then when you reboot, it auto-connects with the AppleID not the username. Under the AppleID, the shares are either not available or available but as read-only.

This is a pain in the ass for me, a tech person. But for "regular" people using the file server, this is a huge hassle. I'm pretty sure they don't even understand what the problem is when I explain it. They made a whole list of all the problems they are having with the new server, not realize that every single item on the list is exactly the same, "can't write to files on the server". It needs to be seamless and easy to use, something Apple excelled at once upon a time.

Addon: Also, one of the work stations is still on El Capitan and it does not have this problem. It seems to be a "feature" of High Sierra. (No Sierra Macs to test on)

No matter what, it auto-connects with the AppleID You can only connect correctly by manually disconnecting, then reconnecting with the right username and password

2
  • Did you ever find a resolution? Have the exact same issue. Thanks. – Stefem Aug 16 '18 at 4:02
  • Unfortunately, I did not. In this case, I just made everyone use that user, so filesharing users are admins. It's a very small office so thats good enough. But in general this is not an ideal setup. – l008com Aug 17 '18 at 8:27
1

I see that this post is one year old but I noticed the same issue today. Finally, I found out that the issue is related to the iCloud Keychain.

I created a fresh new account on my computer and connected to my server from this account : my server username was displayed. Then I connected iCloud with my AppleID in the test account. After that, the server connection was still displaying my server username. After activating the iCloud Keychain service, there was still no issue. But, after enabling the iCloud Keychain AND checking the "keep login in my keychain" option at the server login, the server connexion is now displaying my AppleID.

I think it's a bug in macOS but it's pretty annoying as you can no longer know which username is used for the connection.

1
  • Once I had the auto-complete bug removing iCloud Keychain alone wasn't enough to fix it. I had to log out of iCloud completely to be able to connect to the server with my preferred credentials. I using an app called Auto Mounter on a Mojave machine and I may see if that can run on Sierra. I may also try disabling SMB (use just AFP) or mounting using old "connect to server" where I can embed my username in the connect request. – John Faughnan Sep 12 '20 at 22:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .