1

I accidentally formatted an external USB Drive to APFS, I needed to change it back so I found this walkthrough:

https://www.techrepublic.com/article/how-to-revert-back-to-apples-hfs-from-apfs/

and I ran this command:

diskutil apfs deleteContainer /dev/disk2s2

Now I can't use the USB drive anymore, I can't see it in diskutil via command line.

The only place I can find it is in system information as so:

STORE N GO:

  Product ID:   0x0302
  Vendor ID:    0x18a5
  Version:  11.00
  Serial Number:    1314110000000445
  Speed:    Up to 480 Mb/sec
  Manufacturer: Verbatim
  Location ID:  0x14100000 / 18
  Current Available (mA):   500
  Current Required (mA):    500
  Extra Operating Current (mA): 0

But it doesn't seem to acknowledge that this is a drive, how can I fix this?

  • 1
    Have you tried Disk Utility.app? – IconDaemon May 1 '18 at 17:44
  • 1
    @IconDaemon yes, it won't be found anywhere as a storage device. Disk Utility.app, diskutil, I'm not sure where else to look. – user472755 May 1 '18 at 17:57
  • 1
    If you have access to a PC, maybe it can be formatted via Windows. Is this drive one of these types of drives or something similar from Verbatim? – IconDaemon May 1 '18 at 21:02
  • 1
    @IconDaemon Unfortunately no it's just a usb thumbdrive: walmart.com/ip/Verbatim-4GB-Store-n-Go-USB-Flash-Drive-Red/… it's now mounting (I noticed it mounts after 15 minutes): I get the following results in diskutil: ` /dev/disk2 (external, physical): #: TYPE NAME SIZE IDENTIFIER 0: *4.0 GB disk2 ` However I'm not able to format it or anything. Windows has similar issues, it sees the device as a USB device but it won't let it run as storage. – user472755 May 1 '18 at 21:47
  • 1
    If there's no data on the drive you must retain, the device itself should be relatively inexpensive to replace. If it is brand new, perhaps Verbatim would replace it. I've had a number of thumb drives, cheapos and top-of-the-line models, fail without warning. Good luck! – IconDaemon May 3 '18 at 0:16

You must log in to answer this question.

Browse other questions tagged .