Recently I dropped my iPhone, breaking the screen, so I had that replaced with a new screen by myself that I brought from Amazon.

Now that I replaced it, the iPhone home button doesn't work at all because when I press it, it doesn't do anything, no matter how hard or many times I press it, it still won't do anything.

Later on, I took apart the iPhone and replaced the home button with a new one, and this didn't solve the issue and yet I don't know why it doesn't work at all.

I have pictures of my iPhone 3GS, hopefully it should help or whatsoever.

How can I get the home button working again?

enter image description here

enter image description here

enter image description here

  • 1
    I have the same issue. Which is how I found your question. I even replaced the bottom connector board and it still did not help. I guess the two small pins below the button have to hit the two pads on the buttom board. Where it says J3. But I tried shorting the J3 pads on my phone and that did not do anything.
    – Kobski
    Commented Nov 29, 2011 at 9:26
  • I replaced a screen that was actually for the 3G instead of 3GS and had this same issue. You may want to double check the new screen.
    – Nate Bird
    Commented Dec 2, 2011 at 2:31
  • Nope, I got an iPhone 3GS model screen.
    – MacMac
    Commented Dec 2, 2011 at 13:07

3 Answers 3


Have you checked that when you re assembled the phone you lined up the positioning of the dock connector correctly, a tiny bit off and it will cause the home button to not work.

See this solution for removing the back of an iPhone 3GS for disassembly instructions. On step 29 you will see the importance of this components positioning.

  • But I didn't take off the back part, I just took off the screen and the frame, leaving the board with the phone back part as you can see in my screenshot that I haven't taken off the back part.
    – MacMac
    Commented Dec 2, 2011 at 13:10
  • check connector 4, if you touch that slightly and kncok it, the home will not work. Commented Dec 2, 2011 at 14:18
  • Hmm, I'm sure I didn't touch connector 4, I won't able to know if I touched it or not.
    – MacMac
    Commented Dec 2, 2011 at 15:17
  • its really easy to, so i would move that around until you start to get a response, as that is the connection for the home input button. Commented Dec 2, 2011 at 15:53

If you can't fix the Home button mechanically, you can use a workaround to still be able to use your device, provided you have upgraded to iOS 5 or later.

Enable "Assistive Touch": Settings -> General -> Accessibility. It essentially shows a home button on the screen. A good way to breathe life into a broken phone.


This is probably a bit of a long shot given the distinct possibility of this being a hardware rather than a software issues (because of historical circumstances). Having said that, I did have this same problem with my iPad 2 (was convinced that there was an issue with the hardware) and this was rectified by a 'hard device reset'.

Have you tried this yet?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .