19

So, I restarted my Mac in the morning and I receive this error while trying to start my normal VBox but it did not start instead it gave in an error. This is the error image

3
  • 2
    Did yo perform an update of any kind (macOS and/or VirtualBox especailly)? It's also helpful if you let us know what version of VB and macOS you're using.
    – Allan
    Apr 30, 2018 at 1:40
  • 1
    Its not updated This is the the Version 5.1.14 r112924 (Qt5.6.2)
    – k4b00m
    Apr 30, 2018 at 2:26
  • @Allani have figured out a way from this problem but can you look at this problem = apple.stackexchange.com/questions/324154/…
    – k4b00m
    May 3, 2018 at 23:02

3 Answers 3

15

So, To fix this issue you will need to be in an admin account then you will need the VirtualBox .dmg file download then you will open the dmg you should see something like this Click on the VirtualBox_uninstall.tool file. Then you will see your terminal open and give you this output

Last login: Thu May  3 18:47:27 on ttys000
macname:~ user_name$ /Volumes/VirtualBox/VirtualBox_Uninstall.tool ;        exit;

Welcome to the VirtualBox uninstaller script.

The following files and directories (bundles) will be removed:
 /usr/local/bin/VirtualBox
 /usr/local/bin/VBoxManage
 /usr/local/bin/VBoxVRDP
 /usr/local/bin/VBoxHeadless
 /usr/local/bin/vboxwebsrv
 /usr/local/bin/VBoxBugReport
 /usr/local/bin/VBoxBalloonCtrl
 /usr/local/bin/VBoxAutostart
 /usr/local/bin/VBoxDTrace
 /usr/local/bin/vbox-img
 /Library/LaunchDaemons/org.virtualbox.startup.plist
 /Library/Application Support/VirtualBox/LaunchDaemons/
 /Library/Application Support/VirtualBox/VBoxDrv.kext/
 /Library/Application Support/VirtualBox/VBoxUSB.kext/
 /Library/Application Support/VirtualBox/VBoxNetFlt.kext/
 /Library/Application Support/VirtualBox/VBoxNetAdp.kext/
 /Applications/VirtualBox.app/

 And the following KEXTs will be unloaded: org.virtualbox.kext.VBoxDrv

 Do you wish to uninstall VirtualBox (Yes/No)?

type Yes

The uninstallation processes requires administrative privileges
because some of the installed files cannot be removed by a normal
user. You may be prompted for your password now...

Please enter your_id password:

Enter Your password YOU MUST ME ADMIN OR ROOT

Then Once the terminal is done uninstalling.

open the VirtualBox.dmg again and follow the steps to install it then at the end it will say installing failed or some kind of error.

Open: System Preferences > Security & Privacy . then on the bottom of that window you will see a message to allow access to the virtual box just click that and open Virtual Box you will be good to go but after this i ran into another problem which is not that improtent related to Bridge Adapter. :

Failed to open/create the internal network 'HostInterfaceNetworking-en0' VirtualBox?

9
  • 2
    When I read this answer I gave it a solid 1% chance of working. But it worked, bravo! You saved me a bunch of time. Jan 21, 2019 at 15:54
  • 1
    I follow you message exactly. I stopped at it will say installing failed or some kind of error. i went to Security & Privacy, nothing about Virtualbox. what to do?, i am admin. Dec 21, 2019 at 9:28
  • Okay it worked. the thing i should allow it was American Orcale, Inc nothing about virtualbox. that is way i got confused Dec 21, 2019 at 9:33
  • 1
    (Using macOS 11.4 Big Sur) Since I originally installed via Homebrew, I decided to try applying this answer via brew before resorting to a conventional download and install. The following worked for me: csrutil status (make sure it says "System Integrity Protection status: enabled.") Then brew uninstall --cask virtualbox and brew install --cask virtualbox folowed by a reboot to allow the kext to activate. All my previous vboxes were still listed and they worked. Thanks for the hint! Jul 14, 2021 at 17:57
  • 1
    @dnaatwork.com asks, "correlation"? Slightly. A reductive summary could be: These issues occur when engineers don't follow the install and upgrade path that Apple anticipates and has designed their their test process to verify. Mitigate these by migrating your system state to that which is expected. My state drift was a missing kernel extension. Your drift was a missing licenseAccepted plist entry. Both would have been avoided by a Normie installing via App Store and launching the Xcode GUI 1 time. You and I, "Think Different". ☮️❤️🌈 Nov 10, 2022 at 3:54
7

I realize this is an old question, but as its the number 1 result on google I though I would mention. If you are having this problem on big sur 11.1 and reinstalling hasn't fixed the issue, check and see if you have SIP enabled. In my case it was disabled and re-enabling it did the trick. I suspect that if it's disabled, you know how to enable it, but just in case: reboot into recovery mode, sign in with your user account, go to utilities > terminal and run

csrutil enable && reboot

This fixed the issue for me.

4
  • 2
    +1 to this! macOS 11.1 Big Sur with Virtualbox 6.1.6 produced 'NS_ERROR_FAILURE (0x80004005)' due to SIP being disabled.
    – bafromca
    Jan 6, 2021 at 19:57
  • That was the issue! Thank you so much!
    – freemanoid
    Jan 12, 2021 at 7:43
  • 2
    before apply this, you can check if it is alread enabled by csrutil status
    – sddk
    Nov 29, 2021 at 9:36
  • my SIP is indeed disabled. But after I enable it uninstall and reinstall virtualbox, I'm still not able to see the Allow App prompt in Security & Privacy
    – ychz
    Oct 27, 2022 at 14:26
2

I got this when I was trying to restore a suspended session. The fix was to click the "Discard" button (down arrow icon) and just discard the saved machine state. It's at least faster that uninstall/reinstall, I'd try it first.

2
  • Thanks for this. I was afraid to press Discard because I thought it would discard the VM, not the saved state. This worked for me when an ininstall/reinstall did not. Jul 18, 2019 at 19:53
  • 2
    I having the same problem first time i installed this. have not run it before. where is the discard button? Dec 21, 2019 at 9:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .