2

[ I am in the process of migrating an old MacBook Pro to a new one. ]

I made a complete 8 GB USB "Install macOS High Sierra". I checked it (Disk Utility) from my running old MacBook Pro.

I booted from this USB key on my new MacBook Pro not connected to anything (no Wi-Fi neighbour, no Internet) so as to make a secure and clean initial installation. I proceeded through the following steps:

  1. Disk Utility: I formatted the internal SSD as APFS encrypted case sensitive, and gave the partition a solid password: "password_SSD".
  2. Install MacOS: I selected the just created APFS encrypted case sensitive partition. I entered its password: "password_SSD".
  3. The installer rebooted, I entered "password_SSD".
  4. The installer asked me if I wanted to migrate information from another Mac, TM or external disk. I chose an external disk containing my previous MacBook Pro running High Sierra on HFS+ case sensitive (not encrypted).
  5. I selected to migrate everything.
  6. The installer asked me to choose an admin account. I selected my previous admin account Bob, entered a new solid password: "password_admin". Then I was asked to enter the partition password so that the selected admin could open the encrypted partition: "password_SSD".
  7. The installation process proceeded quietly for 4 hours, and displayed me the following error window error n°1:

    Sorry
    An error occured while transferring your information.
    
    ! Bob could not be created.
    

    But nonetheless proposed me a Continue button. I chose this continue option after so much wasted time (why not to check if I can exit alive from a few hours tunnel).

  8. MacOS High Sierra finally booted and asked me the SSD password: "password_SSD".

  9. The Login Window proposed me to choose from my known users accont plus a great number of daemon accounts: error n°2.

  10. I selected Bob and password_admin. My session opened but any Finder selection gave an error popup window error n°3: "file" can't be opened because the original item can't be found.

It is clear that this installation didn't run correctly. And I searched through the /var/log/install.log which had been filled, but didn't find any intelligent explanation about the size of damage of error n°1.

I tried a slightly different procedure with an external disk and a partition of HFS+ case sensitive (after a full erase of course). The process terminated completely without any of the above 3 errors. 2 differences: APFS / HFS+, encrypted / not encrypted.

I tried another different procedure with the internal SSD and a partition of HFS+ case sensitive. The process produced the same 3 errors as in the initial case.

The problem seems to be around "encrypted" and "migrate".


This is the reason I ask here this question before wasting another chunk of 5 hours.

How to install and migrate to High Sierra on an encrypted FS?

Did I made a big error in my procedure?

Is this a known problem?

How may I further analyze this problem to eventually help to fix it?

  • @klanomath: danke :). – dan May 1 '18 at 13:04

You must log in to answer this question.

Browse other questions tagged .