1

This is driving me nuts.

settings -> Date & Time -> "Set date and time automatically" is unchecked

In terminal:

$ sudo systemsetup -getusingnetworktime
Network Time: Off

There should be absolutely no reason whatsoever for my system clock to change. And yet, and random points through the day, I will try to schedule something on a remote server only to find my own clock is 3 minutes behind. (and it's 3 minutes every time) And every single time I'll open up the Date & Time settings to find that not only has my time changed, the "Set date and time automatically" box is checked and grayed out, even though my settings are locked!

Indeed, I can go into console and see exactly what's doing it:

Apr 27 04:07:35 ... timed[6289]: settimeofday({0x5ae2e857,0xf2489}) == 0
Apr 27 09:19:03 ... timed[6289]: settimeofday({0x5ae33157,0x17a8e}) == 0
Apr 27 12:55:56 ... timed[6289]: settimeofday({0x5ae3642c,0xf2a7c}) == 0
Apr 27 13:30:42 ... timed[6289]: settimeofday({0x5ae36c52,0x54746}) == 0
Apr 27 14:36:03 ... timed[6289]: settimeofday({0x5ae37ba3,0x9c8e5}) == 0
Apr 27 15:52:35 ... timed[6289]: settimeofday({0x5ae38d93,0x61a78}) == 0
Apr 27 15:52:45 ... timed[6289]: settimeofday({0x5ae38d9d,0x57751}) == 0
Apr 27 17:00:04 ... timed[6289]: settimeofday({0x5ae39d64,0x4f83b}) == 0

I think I know what's causing timed to fail: I'm VPN'd in all day, and corporate firewalls stop me from connecting to the NTP servers properly

$ sudo ntpdate -u time.google.com
27 Apr 18:05:22 ntpdate[41606]: no server suitable for synchronization found

Still, I'm not sure where to go from here. SIP stops me from messing with this daemon

$ sudo launchctl unload /System/Library/LaunchDaemons/com.apple.timed.plist
/System/Library/LaunchDaemons/com.apple.timed.plist: Operation not permitted while System Integrity Protection is engaged

What should I do from here? How bad of an idea is it to disable SIP and kill timed?

This is on a 2015 Retina Macbook Pro and macOS 10.13 High Sierra

  • 1) If you turn off time sync, don't complain that your system clock (or the remote server's clock) is wrong. 2) Use an internal time server 3) Try sudo ntpdate -u time.google.com && sudo ntpdate -d time.google.com or two times sudo ntpdate -u time.google.com! – klanomath Apr 28 '18 at 2:09
  • The problem is that not only can't time sync connect to a remote NTP server on VPN, time sync actively sets the time incorrectly and can't be disabled. I would notice the time being off, reset it manually, only to come back later to find that timed has gone ahead and set it wrong, again. I'll try setting up a local time server and see if that helps. – mdong Apr 28 '18 at 17:32

You must log in to answer this question.

Browse other questions tagged .