0

I recently purchased an iMac from a local Goodwill. After talking to Apple support I was able to find out that this is a 2008 all-in-one model. Additionally, I asked for help with the "flashing question mark folder" icon that would appear on startup. After three different people, I still could not get anything to work. Here's what each Apple rep had me do:

Try restarting iMac while holding down various combinations of Control, Command, Shift, Alt/Option, R, P, C, E, etc.

Nothing worked. He told me maybe my bluetooth keyboard was bad - fine, I went out and got a wired Mac-supported keyboard.... and NOTHING happened.

The second person told me that the flashing folder was likely because there was not an installed version of Mac OS on the hard drive (seemed reasonable), so he filled out an order and had Apple ship me copies of Mac OS X 10.6.1 as well as Snow Leopard.

I put the Mac OS 10.6.1 disk in my machine and tried to boot it and nothing happened, and now the disk is stuck in the machine. I have tried several different commands to get it out and nothing has seemed to work.

Finally, they got me in contact with a "senior advisor." He told me that basically the hard drive was the issue and for a computer this old, it wouldn't be worth time/money to continue to invest in it (probably true, but I love a good project).

I decided that the hard drive must be the issue, and sought out a new one. I went to a local Micro Center and purchased a brand new Samsung 256GB SSD drive, x2 2GB RAM modules, some industrial computer tape, and an iFix-it kit.

Here's where I'm at now. I followed several Youtube videos to no avail. I got inside the machine, removed the old HDD and hooked up the cables to the new SSD. I also inserted the new RAM module. I then try to boot up my machine and I hear a rather loud beep and the computer fan starts, but the screen remains black. I know a little bit about computers, so I figure this is a typical case of the RAM not working. I remove one of the new RAM and put one of the older ones in in spot (so the machine has x1 1GB and x1 2GB RAM modules). The machine is now able to turn on its screen. Still though, it boots up to the flashing folder. When I hold down the Option key on reboot I see the mouse cursor appear on a white screen, but nothing else. I don't know what else to do.

I have removed the new SSD and reinstalled the old HDD and the same thing happens. The Mac OS X 10.6.1 disk is still stuck in the optical drive. Does anyone have any ideas on what the problem may be? I feel like I've tried everything and I'm just frustrated at this point. All-in-all I've spend about $300 for the machine + everything else, which is what I could have bought a refurbished WORKING one for. I'm willing to put more money in if you think it will fix my problem.

  • Indeed there is no OS. Since the OS X disk is in the optical drive, you should be able to install OS X and try. – Pratik Apr 27 '18 at 7:14
  • How do I do this? I've tried to do several different commands at start up and nothing works. – Tom Hood Apr 27 '18 at 7:17
  • 2 small things, just to make sure you did them correctly.. Right as the chimes sound, press & hold, for as long as it takes for something to happen [can take a minute or more sometimes] - To boot from CD hold C. To eject the CD, hold the left mouse button. Both of those ought to work, so long as the CD drive is functioning; they are not dependant on the internal HD. – Tetsujin Apr 27 '18 at 7:44
  • 1
    So I was successfully able to get the disk out using the left mouse button hold. I then inserted the other disk front Apple called "Mac OS X Snow Leopard" and this disk actually worked on boot up. I'm able to proceed with Mac OS installation. I guess the disk called "Mac OS X 10.6.1" is just useless. I put the new SSD back in the computer and formatted it using the terminal on Startup and am currently installing the OS onto my new internal SSD. I will keep you all posted with updates but so far so good knock on wood. – Tom Hood Apr 27 '18 at 13:20
  • Mac has been successfully set up! Thanks for the suggestions everyone. I did resolve this issue. If anyone is having similar issues, reach out and I can try to help you. I know how frustrating this can be. – Tom Hood Apr 27 '18 at 20:54

You must log in to answer this question.

Browse other questions tagged .