1

I see this issue reported a lot but all the accepted solutions have not worked for me.

I have created a bootable USB stick using UNetbootin with a Debian image. The USB stick is FAT32 formatted with a GUID partition table.

When I reboot with the usb stick plugged in and hold down option I'm only presented with the MacOS hard drive to boot from.

I've successfully reset the PRAM using option+cmd+p+r keys but this has had no effect.

I've not found any other suggested solutions to the problem. What am I doing wrong?

  • You're really going to have to tell us what you tried & what happened when you did; otherwise we're just going to present the same solutions again. Also, for future ref; blowing the PRAM almost never 'fixes things'. – Tetsujin Apr 26 '18 at 10:04
  • That is everything I've tried. The solutions I've read elsewhere amount to checking the usb is FAT 32 formatted with a GUID partition table and to reset the PRAM. The result was no effect - still no usb drive option in the boot menu. – Sio Apr 26 '18 at 10:07
1

If you have succesfully made a bootable linux USB stck before with your method, try a different USB stick or image. It sounds like you have done this before, which suggests perhaps that the image is not right in some way.

A GUID partition table and FAT format are correct.

Other things to try:

1. Try Etcher: It's simple and free. You can find a tutorial from Ubuntu regarding making a bootable Ubuntu drive with it, but all it really says is "use Etcher."

2. Try Mac Linux USB Loader. It costs ~ $5, and while it only supports certain OSes, Ubuntu is one, so Debian probably works.

3. Try dd - note it is /dev/diskx not /dev/diskxs3 (partition 3 or other on disk x). Another tutorial also has you convert the image; I haven't used that method but it seems to work for people:

dd if=/path/to/image of=/dev/diskx bs=512k && sync

I like to know what dd's progress is, so I use pv, which you can get using Homebrew or Macports:

dd if=/path/to/image | pv | dd of=/dev/diskx bs=512k && sync

You'll probably have to put sudo before each dd command.

I hope that helps - you'll definitely get something to work eventually, whether it's the image, method, or USB stick.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .