A few days ago, my MacBook Air (13", mid-2011) running macOS High Sierra 10.13.4 (17E199) would no longer produced any sound, neither through its built-in speakers nor the headphone jack.

Pressing the volume keys on the keyboard brings up the volume overlay, but with a stop sign underneath, and none of the keys have any effect.

The volume (speaker) icon in the menu bar is greyed-out, and its volume slider is disabled. Option-clicking displays both input and output as grayed-out, with no devices shown.

To be clear: It's not about audio being distorted or noisy or flaky or weird; I don't have any audio output at all.

Apparently, my machine no longer has an audio output device.

Editors, please keep reading before you mark this as a dupe: I am aware that this issue has been asked here many times, but none of the suggested fixes work, so I'm kind of trying to pull all the bits and pieces into a single coherent post.

Trying to fix the issue, I tried all of the following (suggested here and elsewhere), sometimes repeatedly, with no luck:

  • Rebooted the machine (duh); checked if my OS is up-to-date (it is)
  • Plugged a headphone jack in and out repeatedly, also jiggling it around a little, as people have been suggesting that the jack's internal switch may sometimes get stuck and cause this issue
  • Checked the system prefs for sound/audio, which would normally let me select "Internal speakers" as the default output device. But there is no such option, nor any other device to choose from (the selector window is just completely empty)
  • Launching audio/MIDI setup (which showed up with an empty main window), I tried to set up a "main device", which worked, but it said that the main device was not available/present (or something to the effect that the hardware in question is apparently AWOL)
  • Tried fixing permissions on the main volume (but learned that this isn't even possible anymore on Sierra)
  • Did both a PRAM/NVRAM and SMC reset
  • Rebooted into hardware test mode and did both the normal and extended tests; both found "no trouble"

Other than this issue, my machine is completely fine, both hardware and software wise.

Now I’m all out of ideas.

Of course I may also have damaged the sound hardware, but that wouldn't make any sense. First of all, I did nothing to the machine that could have caused this. It was sitting comfortably on my desk all the time. Second, a hardware malfunction would surely result in some kind of problem being reported on the OS side, or would it?

The only thing left that comes to mind is that the audio device driver at kernel or IO device level may have become corrupted or disabled. Could this happen? (If so, how? I haven't changed any system settings, installed any software (especially no "flaky" ones) or did anything else unusual). How could I check for and fix this?

Any help would be appreciated.

[Update, thanks Allan]

The output of running system_profiler SPAudioDataType is

      Manufacturer: Apple Inc.
      Current SampleRate: 0
      Transport: Unknown
  • In Terminal, issue the command system_profiler SPAudioDataType and post the output to your question.
    – Allan
    Apr 26, 2018 at 12:46
  • Thanks Allan! I appended the output to the question. Interesting. Must be a "dummy audio device", but at least it's manufactured by Apple :) Apr 30, 2018 at 14:28
  • if you go to your system info > Audio, what do you see there? A normal mac shows: Microphone (integrated), Input (integrated), Output (integrated) then the name of you device (in my case intel high definition audio), plus all in- and outputs. If I check my device, I see that all sample rates are set... and EVEN MORE IMPORTANT: Under Audio I have entries, not just under devices; and transport says: built-in PD: HAVE YOU TRIED TO MAKE A NEW USER PROFILE ON YOUR MAC, AND CHECKED IF THE SAME HAPPENS WITH THIS NEW UNTOUCHED USERPROFILE? Apr 30, 2018 at 18:05
  • If that's all you're getting after running the command - it means that your hardware isn't being recognized. Most likely, it has failed. Other than replacing the logic board, I would just get a USB audio interface. See: apple.stackexchange.com/a/259681/119271
    – Allan
    Apr 30, 2018 at 19:26
  • @CaneloDigital - the Terminal command in my first comment does exactly that.
    – Allan
    Apr 30, 2018 at 19:27

1 Answer 1


My situation was NEARLY as you described -the issue was on a mid 2011 27" iMac. I had recently replaced/upgraded the original 1TB HDD with a 4TB HDD thinking/hoping it would resolve a problem with vertical lines on my monitor. It did just that, briefly, but then about a day later, the problem returned. I swallowed hard, opened up the iMac again, and replaced the graphics card, upgrading from the original 1GB to an AMD Radeon HD 6970M 2048 MB. To do that, it was necessary to completely remove the logic board as the graphics board connectors are on the back of the logic board (thanks a lot Apple!). It all went back together well, and everything but sound is perfect. It's possible that I could have damaged the logic board at some point, but it seems likely something else given the number of complaints about this with nothing being done internally. Whereas the original poster had NO system out options, I had one - digital output. Internal speakers option had disappeared, although internal microphone and line input functions remained normal.

All the tricks described in detail in others places failed to work, headphones connected to the jack do NOT function, but using a Bose wireless Bluetooth headphone works normally. The solution for me was rather than pour any more $$ into this old machine that is no longer my primary computer was to purchase and pair a Bose portable speaker with the iMac. The sound is much improved over the old internal speakers, I can leave it on it's charging pad to have continuous sound, and I can take the speaker anywhere I want pairing it to the iPhone X or an iPad.

The only thing bugging me is that I couldn't figure it out, but not worth wasting any time over either. Hope you've solved your problem.

Not the answer you're looking for? Browse other questions tagged .