I am trying to install some software, (at this particular moment I want to install VirtualBox, although this issue has happened with other software), and I have to click "Allow" in System Preferences, in the Security & Privacy -> General window. When I click on it, nothing happens, and the button and message stays there.

I looked online, and all of the solutions say that there is some kind of program running that captures/forwards mouse clicks and such, and thus I am not "directly" clicking on the Allow button.

The problem is that I don't know of any programs that I'm running that do this.

I am on a Macbook Pro 13 inch 2016 with touchbar, running macOS High Sierra

  • I am not connected remotely
  • I have tried restarting my computer
  • I have tried running the installer through terminal, with and without the sudo command
  • I have tried right-clicking and clicking on "open" on the .pkg file
  • I have tried unlocking the system preferences page before clicking "Allow"
  • I tried re-downloading the .pkg file

Screenshot of security and privacy window

  • I'm not sure what kind of element we are talking about, but the whole System Preferences window should be navigable with a keyboard: Arrow keys, Tab, Shift+Tab, Space, Enter. As far as fixing this issue goes... Try to reboot to safe mode and see if you can click the same "Allow" in that mode. – Joonas Apr 26 '18 at 6:37
  • Are you able to start the program when you right-click the program and then choose "open"? – Jules Apr 26 '18 at 6:57
  • Welcome to Ask Different! :) It would be really good if you could edit your question to clarify the exact Allow button you're referring to. It may be best to actually upload a screenshot of the window it's on. Also, it may be worth mentioning the software you're trying to install as it could be relevant to the problem. – Monomeeth Apr 26 '18 at 8:17
  • I have edited my post to make it more clear what I'm asking – Abraham Apr 26 '18 at 14:10
  • I was not able to navigate the window using my keyboard, how can I do this? – Abraham Apr 26 '18 at 14:10

10 Answers 10


This worked for me on High Sierra 10.13.4:

  • System Preferences > Keyboard > Shortcuts > Select 'All Controls'

enter image description here


  • System Preferences > Privacy & Security > Press 'Tab' until 'Allow' is selected > Press 'Spacebar'

*Note: the Privacy & Security page may need to be unlocked before 'Tab' will work.

*Note: After open Security & Privacy and selecting General tab you should push tab key to select allow button after that push space bar key!

Hope this helps!

Credit to @dansanduleac's answer on GitHub

| improve this answer | |
  • 1
    This should be marked as the accepted answer in my opinion. – Adam Boczek Aug 10 '18 at 11:49
  • Agreed this is the best solution because it will work in all cases. I was not using remote viewers and had no trackballs, third party keyboards, or accessibility widgets to my knowledge. This solution worked instantly. – emkman Aug 10 '18 at 16:33
  • 2
    WTAF. Dammit Apple, you're unbelievably shoddy sometimes. – mpowered Sep 5 '18 at 4:13
  • 3
    Doesn't work anymore :-/ – Oliver Dixon Sep 14 '18 at 16:44
  • 6
    For the people that still can't, try to close system preferences after enabling "All controls" and try again. Looks like Apple did this on purpose ... – David Lopez Oct 26 '18 at 19:10

If you are connecting to the computer remotely with software such as TeamViewer, VNC etc. it will not work, because macOS doesn’t allow you to press “Allow” button through other applications. You have to directly press that button with your trackpad.

| improve this answer | |
  • I am on my actual computer, and I am not connected remotely. – Abraham Apr 26 '18 at 20:18
  • In this case, I can’t help you, but this answer is still valid. Are you using a mouse? If so, try using the trackpad. Shouldn’t make a difference, but worth to try. – user255044 Apr 26 '18 at 20:20
  • 1
    Unfortunately I am using the trackpad. Solutions I've found online involve this answer, and many people have said they had some software like MagicPrefs, Witch, etc. that capture and forward mouse clicks and such. I might have some services running that do this that I do not know about. – Abraham Apr 26 '18 at 20:22
  • 1
    Did you try safe mode? – user255044 Apr 26 '18 at 20:23
  • That worked! After I got out of safe mode, and tried to install other stuff, it had the same problem. It must have been some software monitoring my mouse and keyboard events, I'll have to look into that. Thanks! – Abraham Apr 26 '18 at 21:01

Nothing was working for me, local clicking, keyboard selection, nothing. Turns out it was a piece of security software that hadn't been authorized correctly. This security software was the process actually "performing" the click. To find out what bit of software or hardware happens to be being blocked, you have to establish what Process ID it uses, then identify the software/hardware from its PID, and go from there, either killing or uninstalling the hardware/software, and repeating until the click succeeds. Man I hate macos.

  1. Open Console ( Finder > Go > Applications > Utilities > Console )
  2. Click, press, tap, space, automator the button
  3. A message will pop onto Console (under your Device's main logs) that looks someting like this: “Dropping mouse down event because sender’s PID (1234) isn’t self or 0”
  4. Open Activity Monitor and sort by the PID field. Find the PID, [force] quit the process, try to click/press/tap/space/automator the button again, should work. If not, repeat this process - probably another PID blocking you now.

Note, the above is NOT a workaround for being unable to use remote software - that just won't work unless you completely disable SIP.

| improve this answer | |
  • Quick note: for me it was VLC which was blocking the click event. You might try to quit both Chrome and VLC if you're in a hurry, if that doesn't solve the problem this method works absolutely fine, thanks! – jlapoutre Sep 23 '18 at 7:26

We can use Apple Script to click on the Allow button as follows:

  1. Press Shift Command 4 to start screen capture (but don't actually go thru with this):
  2. Hover over the Allow button and note the coordinates (e.g. 620, 534)

enter image description here

  1. Open a Terminal window and use those coordinates in a script:

    osascript -e 'tell application "System Events" to click at {620, 534}'

| improve this answer | |
  • The fact that you may need to click this button with the command line is a crazy bad UX – David Lopez Oct 26 '18 at 21:40
  • 1
    Genius complex idea for engineering! – masoud soroush Nov 7 '18 at 1:02
  • Using the osascript method works great, but you cannot see the cursor position info over ARD. Solution was to drag the window to the top-left corner of the screen, and then the coordinates are: {570, 473}. – staze Jan 11 '19 at 23:21
  • You may need to go into Security & Privacy -> Privacy tab and under Accessibility check the box next to the terminal for this solution to work properly. – chris Apr 4 '19 at 7:03

Try safe mode. It should disable any services running at the background, letting you to click the Allow button. You can get into safe mode by rebooting and holding shift during reboot.

| improve this answer | |

for me it worked after i quit VLC

| improve this answer | |
  • For me it wasn't VLC, but I quit Chrome, Skype, Terminal... EVERYTHING. And then it worked. – coolaj86 Aug 7 '19 at 5:20

After looking through some of these answers, I realized that the issue was the Spectacle window manager app. Once I quit that it worked fine.

| improve this answer | |
  • I could reproduce this on my end. – Scorchio Sep 15 '19 at 7:44

It worked for me when I quit Chrome before clicking 'Allow'.

| improve this answer | |

Using Micah Roth's solution I figured out that it was the fact that I was using a Wacom pad. I looked up the process and it was WacomTabletDriver. To fix this I went into System Preferences > Accessibility > Mouse & Trackpad and checked Enable Mouse Keys. You can then use the following keys to move and the center one (5/I) to click. (Image is from https://support.apple.com/kb/PH18381)

use the outer numbers on the numpad or the keys around I on querty to move

| improve this answer | |

I experienced this same issue today with Little Snitch, and after reading and trying a half dozen fairly complicated "solutions" without any success, what worked for me was: close the Chrome app. Problem solved.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .