2

I am planning on buying a MacBook Pro 15" Mid-2015 (not a used one, but a new one directly from Apple). For reasons of running legacy software I would like to install Mac OS X 10.10 on it. When it came out, this MBP was delivered with Mac OS X 10.10.3.

Now, I also know that you can't usually downgrade a system that you newly buy (say downgrade a Late-2016 MBP to OS X 10.10), as it was never available with such an old OS X in the first place.

However, since the Mid-2015 MBP was in fact available with OS X 10.10, I am now wondering: Could I downgrade to OS X 10.10 when I newly buy such a machine today?

2

Interesting question.

Originally these models shipped with macOS Yosemite 10.10.3. However, my understanding is that current models ship with macOS El Capitan 10.11.2.1

Typically this would mean you can’t install a version of macOS earlier than the version it actually ships with and I suspect that would still be the case here.

However, I don’t recall seeing any firmware updates for this model, so it may be possible to do what you want manually (i.e. you wouldn’t be able to do it from Recovery Mode, you’d have to try booting from an external installer or try using Target Disk Mode).

My inclination would be to say it isn’t going to be possible, but in this rare case it may be.

Hopefully someone else who has tried this can chime in here and give you a more definitive answer. You could also contact Apple and see what they say.

1. Last time I checked (admittedly a few months ago - early this year so well after macOS High Sierra was released) these models were still shipping with 10.11.2. However, I am based in Australia and it could be just a case of how fast production batches are selling. I will check again in a couple of hours and update this answer as soon as I can.

[UPDATE]

I've just had confirmation that models being manufactured now ship directly from the factory with macOS High Sierra installed. My guess is getting one with El Capitan pre-installed is going to be a remote possibility at best, and even then that'd be based on whether your location has older stock.

So, installing an older version of macOS depends entirely on whether there's been a firmware update on that model. Unfortunately, some years back Apple started automatically including firmware updates (if/when required) within macOS updates/upgrades and I'm not aware of any current consolidated list of these updates, so it's not easy to check which devices had firmware updates and what those updates meant. Previously you could refer to this page.

In other words the only way to find out with 100% certainty is to try it, but I'd err on the side of caution and assume this won't be possible. I suppose you could ask Apple if you could return it within the return period on the basis that you can't install Yosemite, but they're likely to tell you up front that it's not going to be possible.

The only way to be 100% sure would be to purchase one of the original ones that hasn't been updated beyond Yosemite, although I suspect that won't be easy to find. You'd also be 99+% sure if you bought an original one that shipped with Yosemite but has since been upgraded. However, if you purchased one brand new today that ships with High Sierra, your odds drop to less than 50/50 in my opinion.

  • Are you positive they ship with 10.11.2? I just assumed they ship with the most recent macOS. Is there any way I can find out for sure which OS they ship with? – mdomino Apr 25 '18 at 20:48
  • I know it seems strange. I've added a footnote to my answer and will update it again in a few hours. – Monomeeth Apr 25 '18 at 21:16
  • 1
    @Josh The two avenues I have are Apple's Business Unit and Engineering. My intention is to ask ABU as I speak to them a couple of times a week, plus Engineering are extremely busy at the moment. However, when I next speak with someone in Engineering I'll ask them about this model's current compatibility with Yosemite. Officially the line will be The version of macOS that came with your Mac is the earliest version compatible with that Mac., but I'll suss out if there's an unofficial exception in this case. – Monomeeth Apr 25 '18 at 21:50
  • 1
    I've just done a couple of edits to my answer to remove some ambiguity. My apologies for any confusion. To clarify, if Apple needs to issue a firmware update to address an issue concerning any of its hardware, that update is now included as part of the OS update/upgrade. This does not mean that all OS updates/upgrades include firmware updates, nor that any firmware updates are required for all devices. Also, Apple won't update the firmware on a devices unless there is reason to. It won't update firmware purely to prevent an older OS from being installed, only to fix an issue. – Monomeeth Apr 26 '18 at 23:59
  • 1
    However, in this case this model is still being manufactured and we have no way of knowing what firmware may be included at the factory and what impact (if any) this would have on what you can install. So buying a model that had Yosemite on it originally is a 99.99% safe bet (I can only think of one instance where a Mac was no longer able to have its original OS installed due to a firmware update), but buying a brand new model and trying to install Yosemite is a risk because (1) it didn't come with Yosemite pre-installed, and (2) we have no way to check (without trying it). – Monomeeth Apr 26 '18 at 23:59
1

I assume you expect the 2015 Mac to arrive with High Sierra installed? I state this because in 2015, I could have purchased a 2015 iMac and instead opted for a 2013 model. This 2013 iMac came with the latest version of macOS available at the time, even though that version of macOS did not exist when the machine was made.

My best estimate would be that OS X 10.10.3 would work, but OS X 10.10.2 or older would not. So, if you can download Yosemite from the Apps Store, you would get that last release OS X 10.10.5, which should work. Of course, to download from the Apps Store you would have needed to purchase (for free) when Yosemite first was released. I do not believe you can currently find Yosemite in the Apps Store.

Another option would be to try downloading OS X using macOS Recovery. I recently tried do this for the 2013 iMac and Yosemite downloaded. This Mac was original built to run OS X 10.8.4. The instructions for using macOS Recovery did say the "the version closest to it that is still available".

I should add that I also have legacy software that requires an OS older that High Sierra. I am currently testing running Yosemite in a free copy of VirtualBox. The installation was surprisingly easy. According to the instructions, your model would have to fake the CPU.

  • "The instructions did say the "the version closest to it that is still available"." I don't quite understand, the instructions of what? Do I understand this correctly that you were not able to download 10.8.4? – mdomino Apr 25 '18 at 23:15
  • @mdomino: I added a link to the web page where the quote came from. Let me know if you still do not understand. I think the quote means Apple no longer guarantees you will be able to use the internet to restore a Mac to its "out of the box" condition. – David Anderson Apr 26 '18 at 1:18
  • Hi David, I took a while, but I received my new MBP now and was indeed able to install Yosemite. See the answer I added. Thanks again for helping in figuring this out! – mdomino May 31 '18 at 22:13
1

Yes, OS X 10.10 can be installed on a brand new MBP Mid-2015

Alright, so I just took the risk and bought the MBP without exactly knowing if I would be able to install 10.10 or not. I managed to get it installed.

Here is a rough step-by-step instruction of the process:

  1. Download Yosemite from the App Store (this is probably only possible if you have older Macs and have had access to that OS).
  2. This installer will not run under macOS 10.13 (it will tell you this OS is to old to install). Don't let that throw you off, though.
  3. From this installer you can create a bootable Yosemite install USB-drive. I followed this guide here. I created this image on my old MBP under Mac OS X 10.8.5, but I think this process should work under macOS 10.13, too.
  4. With this USB-drive connected, boot your Mac while holding down the option key. Select the Yosemite install image and install it on the Mac.

Personally I installed I partitioned my drive into two drives, one small one for the Yosemite system and the larger one for the current system.

Since the partition with the new drive uses APFS as the file system, but Yosemite uses (has to use) the older Mac OS Extended (journaled), I am now able to read and write from both systems when I am logged into the newer system, but can only read and write from the older system when I am logged into the older system.

Thanks for the people involved in this thread for putting some effort into trying to solve this question, very much appreciated.

  • Thanks for coming back to share your findings and how you did it! I'm glad this was one of those rare cases where this could be done and I'm sure this will be useful for others! :) – Monomeeth May 31 '18 at 23:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .