I'm trying to add a hyperlink to an image in a slide. I ctrl-clicked the image, chose "add link", then "webpage", but no dialog or field popped up to add the URL. How do I get the URL field to show up?

Screen recording

Keynote version 7.3.1 (and version 8.0.1 - still happening after upgrade), Mac OS 10.12.6

  • 2
    The screencast linked by the OP seems to require Adobe Flash to see. Perhaps you could reproduce with software that does not require Flash? For example Kap. Some of us don't wish to install Flash. Cheers – bjbk May 5 '18 at 0:30

After adding the hyperlink to the picture, if the dialog does not pop up, you can select it using the link icon (circle with arrow) that appears along with the picture.

Note: Be sure the picture is selected when adding the link. +K

If this normal behavior is not happening for you, a restart of your Mac may correct it.

Adding hyperlink to image

Illustration of how to bring up the dialog after setting the link:

Link dialog

| improve this answer | |
  • 1
    Ah, the dialog was not visible for me because the image extended below the edge of the slide. Moving the image up revealed the dialog. – Mike Eng May 6 '18 at 22:04
  • Ah, yes! I hadn’t considered a larger image. But you found it in the place indicated. Glad this helped! Cheers. – bjbk May 6 '18 at 22:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .