1

Intention

I wish to disable message forwarding for all conversations in the Messages app that comes with iOS.

Problem

After updating to iOS 11.3, some message conversations are shared between two devices (an iPhone SE and an iPhone 7) on one Apple ID. None of these messages should be forwarded. In settings, message forwarding is disabled on both devices and “Send & Receive” address sets for each device are mutually exclusive (no address is enabled for both the SE and the 7).

The conversations which get forwarded seem random, with no relationship to how many people are in the conversation, which contacts are involved, who in the conversation (if anyone) is using SMS protocol, or to which phone the conversation is supposed to go; but either all messages in a given conversation are forwarded to the other phone, or none of them are.

None of the other devices on this Apple ID seem to be affected.

Attempted Solutions

First off, I read all of the official support pages for the Messages app that I could find, plus some discussions (this, this, this, this, and this on the Apple community forums, and this, this, this, and this on Ask Different). I also went through an ioshacker article and an imore article that looked sort of relevant. None of this taught me anything new, so I just started trying things.

For each phone, I have:

  1. Permuted all of these actions:
    • toggled “Send & Receive” addresses and then returned these to the desired values (this approach worked for a similar problem in iOS 10)
    • toggled handoff on and back off again
    • toggled message forwarding on and back off again (this is the first time I’ve ever turned that setting on)
    • toggled “Calls on Other Devices” in “Phone” settings and all FaceTime addresses for good measure
  2. Deleted conversations on whichever device wasn’t supposed to receive them.
  3. Restarted the devices.
  4. Reset settings.
  5. Repeated steps 1–3.
  6. Crossed my fingers and hoped really, really hard (I’m quite serious).

On the SE, I have also turned iMessage off and back on again, and logged out of the Apple ID and back in.

Other Notes

  • I don’t have enough running message conversations to do any sound statistics on them.
  • I don’t want to disable iMessage as a long-term solution because (and this might sound stupid) I find the green bubbles stressful.
  • I’ve gotten myself locked out of another Apple ID account trying to fix a similar issue with app syncing, so the “use a different Apple ID for each phone” solution is a last resort, but I am aware that it exists.
  • +1 purely for the format and structure! We need more questions like this. – JBis Aug 23 '18 at 0:34
0

The solution appears to be “wait a few months and let Apple deal with it.” This is underwhelming and probably unhelpful to anyone else who stumbles on this question, but it doesn’t seem like that’s a whole lot of people.

  • Gregory, can I ask, when you say The solution appears to be “wait a few months and let Apple deal with it.” is that because you've had discussions with Apple, or is it just that you're reflecting on this again (maybe even venting a little)? – Monomeeth Aug 23 '18 at 1:10
  • It’s because I contacted Apple, got no immediate help, tried to fix the issue myself, gave up, and noticed the issue vanish less than four months later. – Gregory Gan Aug 24 '18 at 19:26
  • Oh, so you mean the issue has been resolved now? – Monomeeth Aug 25 '18 at 22:51
  • Yes. It appears I forgot to accept my own answer. – Gregory Gan Aug 27 '18 at 16:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .