0

Environment

OS: macOS 10.13.4
Application: Outlook for Mac 2016 (Insider Slow and Insider Fast)
Accounts: Gmail Accounts

I'm switching from Apple Mail to Outlook for Mac 2016. In doing so, I wanted to create an "Unread" and also a "Today" Smart Folder so that I could more easily manage my multiple inboxes.

The Issue

Whenever I create a new search (or use one of the pre-defined Smart Folder searches), the results come back with each message being listed three times with the same time-stamp, and once without any time-stamp (!).

This seems to happen only to emails received in my Gmail accounts. It does not appear to happen with my iCloud account.

If I leave the Smart Folder and click on All Accounts > Inbox, I see just the single email.

Work I've done so far

I've searched Microsoft's KB, search google, searched Apple, but can't find anything.

Any insights?

For anyone out there running Outlook for Mac 2016, especially if using Gmail, what happens when you use Smart Folders? Do you ever see any message repeated?

1

In case anyone else runs into this problem, I found the cause and figured out the solution and am sharing.

The Cause

You'll run into this with Outlook for Mac 2016 and any Gmail account.

The reason why Outlook for Mac 2016's SmartFolder behaves this way is because it is searching on every folder (as one would expect). What I didn't consider was that Google has an Inbox folder and an All Mail folder. When you add a "Folder" column to the view, you'll notice this.

The Fix

To avoid the duplication, you need to update your Smart Folder search so that it excludes the All Mail folder of each Gmail account. The image below shows my Outlook for Mac 2016 with four (4) Gmail account All Mail folders excluded. Image of Advanced Search screen.

If you're not sure how to do this, Click your Smart Folder (or click the upper right Search box and type something and then save to create one).

Click Advanced and then add the following search parameters:
"Read Status->Is->Unread"

Click +

Set the next parameter to:
"Folder->Is Not->Choose Folder". Once you click Choose Folder, a Window opens (titled Window) with a search field. In the search field, type in All and you'll see the All Mail folder. Select it.
The _Choose Folder_ window. If you have more than one account, repeat this with each account.

Click Save Search once you're done.

Now you're Smart Folder will work if you're using Gmail.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .