1

I use Fantastical for my calendar and thus don't want notifications from Calendar.app since they're redundant with Fantastical's notifications. As you would assume I turned off Calendar.app's notifications but they keep turning back on after a certain period of time. I believe this happens on more than one computer of mine as well.

Every single time I go back into System Preferences and disable the notifications for the app and they turn back on after maybe a couple weeks. This has been a cat and mouse game for the last year or so.

Someone has a similar issue with Messages but I'm not sure it's a similar fix: Notifications for Messages keep turning back on in Yosemite

  • Try unchecking Calendar under every account in System Preferences>Internet Accounts – JBis Apr 24 '18 at 19:13
  • in Calendar.app 's preferences, have you set fantastical as your default calendar app? – dwightk Apr 24 '18 at 20:26
  • Regarding Fantastical being the default, I have already done that and it still is set as the default app. Good suggestion, ideally that would be enough. – user478798 Apr 24 '18 at 21:58
  • As for unchecking Calendar under all the internet accounts, I don't think I want that because I want the calendar synced to the computer. If it's not checked I don't believe any calendars would work. – user478798 Apr 24 '18 at 21:59

You must log in to answer this question.

Browse other questions tagged .