2

Problem solved: see "Update 2" section.

I have a MacBook Pro 15'', A1286, Early 2011 which was running OS X Lion and became extremely slow few weeks after an upgrade to El Capitan. The upgrade itself took very long. After the upgrade, the laptop was running smoothly during about 1 week.

Then, performance suddenly dropped and all menus now take a while to open. The mouse cursor is very jerky. The one of the touchpad is also jerky, altough to a slightly less extent. Practically, it is impossible to use the laptop.

The battery is no longer charging and the time (date/hour) is no longer remembered, so that I have to reset it after each start of the OS.

(skip) Specifications : Processor i7 @ 2,3 GHz with 4 GB RAM (skip)


Update 1

  1. Upgraded to 8 GB RAM.
  2. Shrinked OS partition.
  3. Cloned to SSD.
  4. Checked SMART values.
  5. Checked file system.

Problem not solved.

(skip)


Update 2

Short version:

The culprit is the low battery After thorough tests, I came to the conclusion that the jerky cursor movements and the MacBook coming slower and slower was caused by the battery with "replace now" status.


Long version or how the problem has been identified.

I first followed this procedure in the comments of a video showing how to fix battery issue on a MacBook:

  1. Power off computer
  2. Remove battery
  3. Disconnect magsafe
  4. Connect magsafe
  5. Connect batte
  6. Power on

This had the positive effect that afterwards, the date/time were remembered, although the battery was in very poor ("replace now") condition.

Then, I reset SMC and NVRAM, following the procedures linked by users Nimesh Neema and Amey. The problem remained. The MacBook was fast during the first seconds and then went slower and slower. This happened even when using softwares from Apple only and not from third-parties.

Lastly, I tested the MacBook with the battery from a 13'' inch (A1278) MacBook Pro. Both batteries operates at the same voltage (although thus of the 15'' has higher capacity). The battery connector is not a the same location, but is same, so that I could insert it and hold the battery with my hand. This battery was in better condition (with "must be checked" status, but didn't had yet the "replace now" status. This totally solved the problem. The MacBook remained fast and the cursor movements, from the touchpad or mouse were still smooth after several minutes.


Conclusion: If the battery has the "replace now" status, some artifacts totally paralyze the MacBook Pro, although it appears working correctly during the first seconds. This is a purely hardware problem and system reinstall or upgrade is NOT necessary.

7
  • Thank you for mentioning the other thread, that I was not aware of. However, I struggle to be convinced by the answers brought to it. Sure that swapping the HDD for an SSD and adding more RAM improves performance. I've done it many times. However, I have many other computers with an HDD, 4GB RAM and Core 2 Duo or i5 processor which perform way better -- and even with only 2 GB RAM-- whilst my MacBook Pro has an i7. How to explain the jerky mouse moves? Is El Capitan so ressource hungry? Are task performed in the background to artificially slower El Capitan; something like planned obsolescence?
    – OuzoPower
    Commented Apr 25, 2018 at 7:33
  • This article strongly suggests planned obsolescence of the Early 2011 MacBook Pro running newer versions of OS X: link
    – OuzoPower
    Commented Apr 25, 2018 at 7:40
  • Did you do a clean install or did you upgrade leaving your old files intact? I'm running El Capitan on 2009 MacBook Pro and it's extremely fast. Never clone a drive as part of an upgrade - you just bring whatever problems plagued you to begin with
    – Allan
    Commented Apr 28, 2018 at 13:04
  • As described at the first paragraph, it was an upgrade from OS X Lion, not a clean install. The clone to an SSD was performed afterwards, only to confirm that the problem came from the software and not from a slow hard drive.
    – OuzoPower
    Commented Apr 30, 2018 at 13:16
  • Do a clean install. Meaning wipe the SSD and put High Sierra on then use Data Migration.
    – Allan
    Commented Apr 30, 2018 at 13:31

1 Answer 1

0
  1. Perform Apple Hardware Test to check for any hardware failures. To do so, power up your Mac, then immediately press and hold the D key. Keep holding the key until you see the Apple Hardware Test icon. Thereafter follow the steps as mentioned in the support article, How to use Apple Hardware Test on your Mac.

  2. Reset SMC and NVRAM.

  3. If the hardware test passes, try reinstalling OS X El Capitan. If the problem persists, fallback to Mac OS X Lion.

5
  • Thanks, I'll try. The reason why I upgraded to El Capitan was that GarageSale 7 required it.
    – OuzoPower
    Commented Apr 24, 2018 at 13:13
  • The Apple Hardware Test doesn't start. On my MacBook, holding the D key down just after startup delays the display of the "apple" logo, but doesn't make the "world" logo to appear instead.
    – OuzoPower
    Commented Apr 28, 2018 at 12:40
  • hold down Option-D at startup
    – Amey
    Commented May 1, 2018 at 5:39
  • Thanks. I did it, followed by the hardware test. The only detected hardware problem was the battery.
    – OuzoPower
    Commented May 5, 2018 at 17:36
  • It did not worked, but after several tests, I found the origin of the problem, which is confirmed being the battery with "replace now" status. See in update 2 of my original message how I came to this conclusion.
    – OuzoPower
    Commented May 5, 2018 at 23:24

Not the answer you're looking for? Browse other questions tagged .