5

I am using macOS Server's Time Machine service to centralize backups for my mac workstations/laptops. One of the laptops hasn't been backed-up since upgrading to a new MacBook Pro (using Migration Assistant) 6 months ago. I'm now connecting the laptop Time Machine to the server, but instead of using the old backups with the same name, it's creating new ones with a "1" at the end of the name (e.g. MacBook Pro 1 when the name of the existing backup and mac is MacBook Pro).

How do I force Time Machine to use the existing backups so that we may keep all the backup history?

For what it's worth, I believe the macOS Server Time Machine service is no more than a SMB share from the laptop's perspective.

I have seen posts on how to do inherit a Time Machine backup on a locally attached drive, but I'm not sure how to do this on a remote sparsebundle.

5

As it turns out, it is super easy with a single Terminal command.

First, you need to mount the Time Machine share using Finder. Just browse to the server, then to the share so that it mounts. I mounted with Admin privileges since Admin owns the the Time Machine sparsebundle.

Then, you open Terminal and run this command:

sudo tmutil inheritbackup "/path/to/backup.sparsebundle"

For example, mine would be:

sudo tmutil inheritbackup /Volumes/Time\ Machine/MacBook\ Pro.sparesebundle

If your prefer to use quotes intead of the space escape, you should be able to do:

sudo tmutil inheritbackup "/Volumes/Time Machine/MacBook Pro.sparesebundle"

You will need to enter your Admin password, and that should do it.

I rebooted after this, then selected the backup share in Time Machine and now it's using the existing sparsebundle instead of creating a new one.

  • When I run the 'inheritbackup' command, I get the following error message: Usage: tmutil inheritbackup machine_directory tmutil inheritbackup sparse_bundle /Volumes/Ben's Time Machine/Backups.backupdb: Invalid target Any idea what I'm doing wrong? Also, is there a confirmation message or anything that should appear when the inheritbackup command runs successfully? – Yeti yesterday
  • Perhaps /Volumes/Ben's Time Machine/Backups.backupdb is not properly formatted/escaped. Did you include the double-quotes around it? – Swisher Sweet 19 hours ago

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .