1

ALL,

My project is located on GitHub which recently switched to using TLS1.2, which is incompatible with the OpenSSL version OSX 10.8 ships with.

So I tried to build Git from sources.

I downloaded the archive, unpack it and created config.mak file where I put following:

NO_GETTEXT=Yes
NO_OPENSSL=Yes

The build finished successfully, but when I tried to run it I still received:

MyMac:dbhandler igorkorot$ /Users/igorkorot/git-2.17.0/git pull
fatal: unable to access 'https://github.com/oneeyeman1/dbhandler.git/': error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

Is there an easy way to check what version of OpenSSL will be linked if I remove the line NO_OPENSSL=YES from the config.mak file? I will try to remove that line and do make clean && make after that. I did update whatever the notification was suggesting, but don't know if OpenSSL was part of the update.

I just need the latest version of the library. Hopefully there is still one available for OSX 10.8.

The machine is old and I don't want to install anything extra (homebrew or such) unless absolutely necessary.

TIA!

  • Why nt upgrade macOS? – user151019 Nov 4 '18 at 19:08
1

I had Homebrew installed already, so these four steps were enough:

  1. brew install openssl
  2. brew install git
  3. mv /usr/bin/git /usr/bin/git.old
  4. Add [http] sslVersion = tlsv1.2 to $HOME/.gitconfig

Note that you need to install new openssl before building new git, otherwise it will link against the old system version of openssl.

  • As long as /usr/local/bin is before /usr/bin in PATH you shouldn't need to rename the old one (which AFAIK requires you to disable SIP anyway). – nohillside Nov 4 '18 at 17:45
  • @nohillside True for recent versions of Mac OS X; but SIP doesn't exist on OS X 10.8. Not sure about the PATH, whether homebrew somehow had different default configuration on old versions, I think the PATH order is correct on later ones automatically also. – jpa Nov 4 '18 at 17:48
  • Ah, 10.8, didn't notice this before. – nohillside Nov 4 '18 at 17:49
  • @nohillside Heh :) I guess I'm not the only one running ancient build servers and not wanting to touch them more than necessary. – jpa Nov 4 '18 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .