This screen came after I entered my credentials to login, and stayed here for a long time. I have tried reinstalling the os and clearing nvram, tried booting into safe mode and run diagnostics and tried updating the OS, but nothing has worked. How do I get to log in?

enter image description here

  • Did you do anything to it before this behaviour began, and have you left it to run for a few hours?
    – Scottmeup
    Apr 22, 2018 at 15:42
  • I have left it for two to three hours and was the same.I haven't done anything randomly one day this pops up.
    – Saman
    Apr 23, 2018 at 4:54

5 Answers 5


Try creating a new admin user (follow the steps below) and see if this new user can login without this problem. If the new account also experiences the problem I suggest using Recovery Mode to install a new copy of macOS/OS X as it could be a problem with a preference file or other system resource.

  1. Start up the Mac whilst holding down ⌘-S. After a few moments, you'll see the Mac boot to the command line.
  2. The following command will check the filesystem to ensure there are no problems. Enter:

    /sbin/fsck -fy
  3. The next command will then mount the filesystem for it to be accessible:

    /sbin/mount -uw /
  4. With the filesystem mounted and accessible, it's time to remove the file so OS X will re-run Setup Assistant:

    rm /var/db/.AppleSetupDone
  5. After that, simply enter reboot and your Mac will restart and boot normally. Only this time, Setup Assistant will launch.

Create the new admin user and continue through the setup process then sign in as this user.

To re-install macOS/OS X follow these steps:

  1. Restart your Mac whilst holding down Command (⌘)-R to startup in OS X Recovery
  2. Select Reinstall macOS (or OS X, if your using an older OS) from the options displayed and follow the steps presented

This process does not delete the original System nor does it delete your user accounts or personal data. All existing user accounts will continue to work as before and all personal data will be left intact. Some applications may require reinstallation if using this process as they sometimes install elements of their resources in the /Library folder.

  1. reset Nvram or Pram (Command + Option + P + R)
  2. reset Smc (press Shift-Control-Option on the left side of the built-in keyboard, then press the power button at the same time. Hold these keys and the power button for 10 seconds.Power Cord Should be Connected The Light Would Change from orange to Green

  3. Shut down your Mac. Remove the battery. Press and hold the power button for 5 seconds. Reinstall the battery. Press the power button again to turn on your Mac.

  4. Hardware Test . Make sure that your Mac is on a hard, flat, stable, well-ventilated work surface. Shut down your Mac. Turn on your Mac, then immediately press and hold the D key on your keyboard. Keep holding the D key until you see the Apple Hardware Test icon: Select your language and click the right arrow. If you aren't using a mouse, you can use the up and down arrows to select a language, then press the Return key. To begin testing, click the Test button, press T, or press Return. Optionally select "Perform extended testing" before beginning the test. This performs a more thorough test that takes longer to complete. When the test is complete, review your test results in the lower-right section of the window.


  5. If you have backup On time Machine Try Restoring It .

  6. Last option Is Internet Recovery . Shut Down your laptop Press Command + R And power button to boot in internet recovery and if you were running sierra than command + Option + R and power button and format your hdd and reinstall os .

Logging into the computer using a ssh connection I noticed that the user is fully logged, simply the loginwindow does not closes. And what is happening is that the keychain does not unlock. Reboot in safe mode. It will ask you to create a new keychain or update the password.


Based on the photo, this was the same situation I had after migration assistant from something old to Monterey. What worked for me was something based on a solution by Dirk: https://apple.stackexchange.com/a/412232/66547.

The full solution with my additional steps are here: https://apple.stackexchange.com/a/436402/66547

Hope this is of help to future viewers.


This question Macbook Pro stuck after I enter my password provided a solution for me by deleting some .csstore files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .