I asked in the Apple community Mac OS X forum seven days ago - no answers. https://discussions.apple.com/thread/8357828

My late 2012 mac mini 6,2 16gb with 1TB fusion drive refuses to upgrade from 10.13.3 to 10.13.4 reporting "some updates were not installed. details/install".

i have tried:

1) app store upgrade

2) update combo 10.13.4

3) booted to recovery mode, ran disk repair on internal Fusion drive, which found and repaired errors, rebooted, then tried update combo (repeated verify/repair cycle no errors found, no fixes needed)

4) Disconnected two external TM drives, ran update combo

5) booted to safe mode, ran update combo

6) turned off google updater with script, ran update combo

#!/usr/bin/env bash
osascript -e 'tell application "GoogleSoftwareUpdateAgent" to quit'
sudo launchctl unload /Library/LaunchDaemons/com.google.keystone.daemon.plist

7) held shift during update combo reboots

8) Removed Google Updater which was filling log with lots of failed update messages

9) Level 1 Apple support: App Store Featured page High Sierra which failed with unable to unmount to perform repair.

9) More Apple Support - a couple more tries working with level 3 which is reviewing collected logs and settings, and screen shots.

  • Please move the part answering your own question (i.e. your last edit) to a real answer!
    – klanomath
    Commented May 5, 2018 at 17:48

2 Answers 2


You may want to consider yourself lucky as there seems to be a lot of people reporting problems with this particular update of macOS.

If you just Google "Mac OS 10.13.4" you will get a number of articles showing problems with just the update, not to mention the things that it breaks.

Yeah it installed fine for me and probably a lot of people, but enough folks had enough issues with this update that I think your best bet is to not install this update and wait for 10.13.5 to be released.

  • I helped fix a borked High Sierra upgrade. Clean installed regular Sierra. I'd skip this upgrade for a while. Probably slows your computer to make the battery better lol Commented Apr 22, 2018 at 7:14

FIXED Finally:

I worked with Apple support to run this by the developers, and the result came back: no idea how the update corrupted your fusion drive. Only solution is to erase fusion drive, install 10.13.4 and then restore apps and data using the migration assistant.

This is not for the light hearted, but it worked. See http://www.wiredbob.com/2013/12/clean-installation-of-fusion-drive.html

(The secret to success was booting from my MtnLion8.3ESD USB stick, deleting the fusion drive, then re-creating the "Macintosh HD" fusion drive, installing 10.13.4 clean, and then the magic of Time Machine/Migration Assistant. )

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .