4

I guess since up 'upgraded' to 10.13.4 I get a login screen if I leave my MacBook air alone for the briefest time. This is a real pain in the neck.

In system preferences the this statement is checked:

"Require password [immediately] after sleep or screen saver begins."

I can't uncheck this box, and I can't change the [immediately] to anything else. If I could change it to 8 hrs I wouldn't be so unhappy, but as it is it is intolerable. Makes me want to go back to Linux.

I live alone and I have never taken my MacBook to any place public. I guess Apple in their wisdom thinks that if I go to the kitchen to freshen my coffee someone will bust down the door and steel all my secrets.

I would be glad to downgrade my OS if I could figure out how, and if that would actually make a difference.

I hope someone has a solution for this, I'm at wits end.

  • My Mac runs Sierra, so I'm not sure if this is applicable to High Sierra. Are you in System Preferences > Security & Privacy > General ? Is there a small lock icon in the lower left? Can you click on the lock to unlock the pane? – DavidSupportsMonica Apr 22 '18 at 19:51
  • Yes, I click the lock, the lock unlocks, but I still can't change anything in this preference pane. – John Velman Apr 24 '18 at 1:10
  • I made a new admin user for myself, so I now have two admin users, both me. The new one works like it is supposed to. The old one still doesn't work. – John Velman Apr 24 '18 at 1:11
  • Glad you found a solution. I'd ditch the not-fully-functional user. And your comment is actually an answer to the original question, and so should be presented in the answer box and not as a comment. – DavidSupportsMonica Apr 24 '18 at 1:55
1

I was stumped with some issues for days now, reading everything I could on the subject, and I finally found the solution: it is a keychain problem with as simple solution.

The solution is to delete one or more folders located in ~/Library/Keychains/, that is to say folders in the Keychains folder in our user Library.

The folders to be deleted have long names like: A8F5E7B8-CEC1-4479-A7DF-F23CB076C8B8.

You may have one or more folders with these long names and they can be safely deleted: one such folder will be recreated after rebooting.

Do not remove anything else contained in you Keychain folder, and reboot.

Once rebooted, reinstall all extensions in Safari, and/or enable other features you we having issues with.

Trashing those folders solves many issues such as:

  1. Security login screen system prefs not recognizing your changes & your password (locks the screen immediately on sleep or screen saver);

  2. Safari disabling all your extensions and not recognizing your password if you try a solution in the developer's menu;

  3. iCloud system prefs not wanting to enable your iCloud Keychain and complaining it can't communicate with the iCloud server;

  4. Safari not recognizing your password when you try to access the passwords tab in Safari preferences;

  5. Login screen disregards Automatic Login settings and insists on asking for a user password.

——

I found this solution at TechRaptor (thanks!), although at first it seems a bit unrelated (many screen captures in article): The Iron Mac: How to Get Rid of Annoying Local Items Keychain Box.

0

Well, this isn't exactly an answer to the original question, but it is a workaround. I set up a new admin user with a slightly modified version of my real name (still real, but included an initial I didn't include before). New 'short name', 3 initials instead of two. I miss my old user short name. I've been jr ever since PDP11 and ATT Unix PC days. Oh well. Anyhow, the new jrv account works like it should, but the other one still doesn't work.

In a way, it wouldn't be bad to abandon the not completely functional account, since it has a lot of detritus accumulated over the years. On the other hand, it is taking quite some time to get my dropbox folder installed on the new account. I wonder how hard it will be to get my Xcode going with my developer credentials (new to this).

0

i was having the exact same problem. to fix it simply change the password.from there you will be asked if you want to use a separate password. choose yes and change, once done change back to the original password. after your iCloud might ask you to sign in again. once that is done you should be able to turn off screen lock.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .