2

I have iBird Pro on my old iPad and it has stopped working because I "updated" it and the new version requires an internet connection. Even with a connection it does not work and I just get Flickr ads, no pictures of birds.

Before it did not require an internet connection at all. So, basically my app has been ruined.

Is there any way for me to go back to a previous version so I can see bird pictures again?

1

Yes, assuming you have backups of your Mac/PC, the right version of iTunes (or some other software capable of syncing apps) and that the old version of iBird Pro still runs on the version of iOS you have on your iPad.

Essentially what you would need to do is check what version of iBird Pro is stored with your iTunes Library on your Mac/PC (or within your Time Machine or other backups)? Basically you need to go back far enough in your backups to see whether you still have the old version:

  • If so: you can select and sync the iBird Pro app from your iTunes library to your iPad.
  • If not, and you have a Mac: Your Time Machine backup should have backups of all the apps previously downloaded/synced with your iPad. These will be located within your iTunes Library. So you could go back far enough to find a version of the iBird Pro app that will work with your iPad and restore that version to your iTunes Library. Then select and sync that version to your iPad from within iTunes.
  • If not, and you have a PC: Assuming you have past backups of your iTunes Library, you can do the same as above (i.e. copy back a version of the iBird Pro app that will work with your iPad to your iTunes Library. Then select and sync that version to your iPad from within iTunes.

IMPORTANT:

  • You should read the following before proceeding, as Apple has recently changed whether iTunes can still do the above. In a nutshell you will need iTunes 12.6.3 or earlier if you're on a Mac, or you'll need to use 3rd party software such as iMazing.

  • You should delete the current version of the app from your iPad prior to syncing an old version across.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .