17

I've read through a similar sounding problem here: My MacBook pro Wi-Fi is slow, other devices are OK.

However, my MCS index, Transmit Rate(Tx), RSSI and Noise seem to be relatively acceptable. See screenshot here:

This all seems ok from what I've read, however, the Wi-Fi still runs very slowly on my Mac. When I run an internet speed test my download speed is consistently < 1Mbps when it's above 20 on all other devices.

2
  • Model of your Mac? macOS version? Please edit your question with the relevant details.
    – Allan
    Apr 20 '18 at 23:14
  • What year is your mac and what version system are you running?
    – Natsfan
    May 13 '20 at 0:56
18

After speaking to a friend I established that this problem is potentially due to the macOS Sierra update. I followed the first step in this link - removing existing Wi-Fi preferences. Which seems to have worked for now.

6
  • just wanted to say thanks to cb1234 his solution above on this link worked perfect for me !! thank you so much !! osx daily fix wifi in sierra link
    – Tbo Rven
    Oct 4 '19 at 11:20
  • This also works with similar issues on Catalina!
    – PepeToro
    Nov 16 '19 at 13:48
  • This works great for me. Unfortunately the problem keeps recurring almost daily. I repeat the fix in the link above and it's fine again for another day, then sows down again. If anyone has any advice on what could be causing this please let me know!
    – Cian
    May 12 '20 at 14:52
  • Thank you so much. My 2015 MBP seemed get very slow wifi speeds in a corner guest room while all the other apple devices were very fast. This was the fix.
    – eggie5
    Jun 10 '20 at 19:36
  • if apple could address this issue would be cool!
    – confiq
    Dec 10 '20 at 9:55
9

I had the exact same issue. I went through every link on every result from Google by others who had this issue and nothing worked for me.

A user in one of the Apple threads suggested creating a new user profile, because that had worked for them. When I created a new profile, I got an incessant popup that asked me to login to a VPN account (I have NordVPN but it wasn't running at the time and I barely use it) -- this popup was blocking my access to my wifi though! So I rebooted in safe mode and logged into the new profile. Sure enough, the wifi was back to being fast.

I looked up info about the popup and apparently it's another known issue on Macs, and the only solution is to uninstall the VPN. So I deleted NordVPN, and the wifi was working fast on the new profile. Then went back to my main profile to start the process of migrating that account data to the new account, only to notice that the wifi was back to being fast on my old profile too now!

So tl;dr:

Try uninstalling your VPN. I have no idea what the problem was, but in the end, deleting my NordVPN app worked when none of the other solutions made any difference.

4
  • 5
    I had this problem for a year. I try EVERYTHING. I had a software called Pulse Secure (to connect to my workplace). I uninstalled it and BOOM! Problem fixed.
    – callback
    Aug 3 '19 at 21:12
  • 3
    This is insane. I had the same problem, and after reading this I deleted "ExpressVPN" on my mac, and my speeds went from 100 Mbps to 400+ Mbps! This is kind of ridiculous. There's no reason that an app that's not even running should be slowing down your internet so much.
    – oxeimon
    Sep 5 '19 at 20:39
  • Wow, this is crazy, and it works. Sep 13 '19 at 15:13
  • I deleted my vpn (Fast* vpn) from the mac applications folder and re-run the test and yes, it did work! I have pulse secure on another machine but unfortunately, pulse secure on my other machine is for work. I can't just delete it as connecting back to office. Download speed was from 29 and went up to 104. Upload speed from 18 went up to 283. I now know the effect of a vpn on a machine... Feb 26 '20 at 7:38
6

You are on the 5 GHz band, and you don't mention what is your Mac model. So maybe you have the same problem I had.

I found that the WiFi on my MacBook Pro (late-2013) works slowly on 5 GHz / 80 MHz channels (topping out at about 30 Mbps). Enough so that it's at least 3x faster when connected to the 2.4 GHz band in the same router (and I say at least because I can't measure any higher). So, if your router works in the 2 bands and your Mac is switching between them transparently (as it usually does, which usually is advantageous), then you would be seeing big, mysterious changes in speed.

The solution for me was to set the router to work on 40 MHz channels in the 5 GHz band; before, it was set to Auto channel width, which makes it try using the 80 MHz width, and looks like the MacBook didn't like that. Interestingly, an iPhone 7 and iPad Pro had no trouble with it.

(Some more context and info moved to a blog post)

2
  • 2
    This is a great advice. I changed the bandwidth settings from 20/40/80 to 20, and the speed skyrocketed from 40 Mbps to 130 Mbps. Thank you so much! Sep 13 '19 at 15:26
  • Thank you! I had been having issues since getting my keyboard replaced (they updated to Catalina) and I'm using a shared SSID on 2.4 and 5Ghz range (opportunistic upgrade). I'd noticed my MBP was connecting on 2.4 all the time, and dropping out randomly - sometimes causing me to restart many times a day. Thanks to you I realised what it was - My MacBook didn't like the 5GHz channel that was auto set. Everything else worked fine, but the internet is plagued with Catalina users having issues that come and go between upgrades - likely due to frequency changes! Thanks again!
    – JD Byrnes
    Feb 14 '20 at 4:33
1

I had the same problems but eventually found the culprit - an app called Weather Underground. Deleted it and problem solved. Suggest installed apps are a good place to start resolving this problem.

1

I have been seriously struggling with my WiFi every morning in my new office and could not figure out why. Speedtest was 'very slow' on my Macbook Pro 2015 and super quick on iPhone 8, it has been painful and driving me nuts!! It usually got quicker throughout the day, but unbearable in the morning.

After reading the above post about the VPN, I searched (cmd + spacebar) for 'vpn'. I had no applications installed but there were about 4 files with name vpn in them in a resource folder within After Effects, I had no idea what they were but they were being modified constantly!

I deleted them and boom, my internet went fine! Hope this helps someone and I hope that has fixed my issue for good.

0
1

For me the problem was only at 2.4Ghz.

Luckily i could configure my router to only use 5Ghz. now it finally works!

2
  • Welcome to Ask Different. Please refrain from adding comments as an answer. You can see How to Answer for tips on providing quality answers to well-written questions.
    – fsb
    Apr 24 '19 at 13:49
  • This seems to work for me too!
    – willem
    Feb 5 at 18:20
0

I had to create a new profile and disable location services in Security settings to make it work.

It seems this setting in macOs 10.15 greatly effect wifi connection speed, when you download something it likes that you got a speed limitation.

1
  • I am sorry this is not the final answer, after switching to home network this happens again, I have to use a cable connect to my router to make sure network is fine, and solve this wifi problem by... a reboot.
    – Kun
    Nov 11 '19 at 12:53
0

It is very annoying but I think Mac books uses very bad quality wifi network card. My wifi router shows connection speed between devices and router. There is only one wall between router and my mac. My mac's speed is barely above 5 Mb and I usually see 1 Mb. Even my ping from mac to router takes 2 seconds sometimes. If I move my mac to next to the router, speed increases to 130 Mb. Hence, my 5 years old iPhone 6s is never below 50 Mb, 7 years old sony android speed is never below 70 Mb. Sometimes, I think there is maybe a iWifi product by Apple which I have to buy to get better wifi connection just for I can use wifi in another room. My solution is to take a wifi router exclusively for my mac will work just 1 meter away from the mac.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .