1

I always keep the Mail application running in the background (there is a dot below the Mail icon in the Dock but a Mail window is not open) to get notifications about new messages. When I finish work, I don't turn my MacBook off, I make it sleep by shutting the screen pane down. Every time I awake the MacBook in the morning, a Mail window opens as soon as an Internet connection is established. It is very annoying. How to prevent Mail from opening the window on the day first login?

The «Open at Login» option is not turned off in the Mail context menu in the Dock. The Mail application is not listed in «System Preferences» – «Users & Groups» – «Login items».

Environment:

  • MacBook Air 13" 2012
  • macOS 10.13.4
  • Mail 11.3

Update. Starting from macOS 10.14 Mail opens not only on login but occasionally with no apparent reason (it is very annoying when I'm using a fullscreen application).

  • 1
    What’s wrong with closing mail? Don’t notifications arrive if you have power nap enabled and enable push? – bmike Apr 20 '18 at 2:08
  • @bmike If I close (⌘Q) Mail, I don't get notifications about new messages. I have power nap enabled and notifications arrive but only if I keep Mail running. It's OK to run Mail but I don't want it to open it's window in mornings by itself. – Finesse Apr 20 '18 at 7:30
  • Aah - Unless you want to put it in another space and settings to not pop up the window - I think the window raising is part of the notification chain. Hopefully someone knows how to hack it and answers other than "no - we don't know how to hack this or configure this" – bmike Apr 20 '18 at 13:36
2

This has been an ongoing issue since I got my first Mac way back in 2014. There are a lot of window related issues with mail, but they haven't been resolved for years and probably never will be. Sorry to tell you you're going to have to get used to it. Another annoying problem I've experienced with every Mac I've ever used now is if you have a Mail message open in its' own window but not the main window and you click the Mail icon in the dock it'll open the main window on top of the message window. Intuitive!

  • 1
    I don't have the annoying problem you describe. When I click the Mail icon in the Dock, all the Mail windows go to the foreground and their order is preserved. So if I have a message window on top, focus on another application and click the Mail icon, I get the message window on top. – Finesse Apr 21 '18 at 9:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .