2

OSX 10.13.1

The App Store shows a badge of "3" on the icon, but opening it and pressing "Updates" will result in an indefinite hang with low CPU utilization.

Tried going into the terminal and running "softwareupdate -l --verbose". I get "Finding available software" and that's it. It never returns more or accepts input again. Both using my admin account and then doing "sudo su" and running the command with sudo get the same results.

Any ideas? Thank you!

  • Open Console.app and select All Messages under SYSTEM LOG QUERIES in the Sidebar. Enter deny mach-lookup com.apple.securityd.xpc in the search field at the upper right. Let me know what (if anything) shows up. – Doc G. Apr 19 '18 at 6:42
  • Closest matches. These pop up right when I hit the updates button in app store: 'kernel Sandbox: App Store(27497) deny(1) nvram-get BSD Name kernel Sandbox: suggestd(336) deny(1) mach-lookup com.apple.locationd.desktop.synchronous kernel Sandbox: MTLCompilerServi(27504) deny(1) file-read-metadata /Users/gavinc kernel Sandbox: MTLCompilerServi(27504) deny(1) file-read-data /Library/Preferences/.GlobalPreferences.plist kernel Sandbox: App Store(27497) deny(1) iokit-open AppleUSBMultitouchUserClient kernel Sandbox: App Store(27497) deny(1) nvram-get glk_free_policy_override' – kathode Apr 19 '18 at 14:59
  • [Sorry for the delay in getting back to you; no Internet access all day.] Click on the disclosure triangles at the left end of each of the entries you listed. In the resulting expanded texts, look for any buttons which say "Open Full Report" (or something similar). Click any such buttons wherever you may find one. In each of the reports which appears as a consequence, search for these words: credentials instrument auth_entity. The context in which the words appear doesn't matter--just which ones show up at all. Let me know. – Doc G. Apr 19 '18 at 23:44
  • I'll save some time, possibly: if none of those words show up, then my ability to offer suggestions is at an end. If credentials appears, then there is an issue with your Apple ID (possibly your Apple Developer ID, if you have one). The appearance of either of the other two words would require further questions on my part. – Doc G. Apr 20 '18 at 14:08
3

Thanks for the help on this! I finally figured it out, well sort of. I found in the logs a recurring softwareupdate error where a mkdir command was failing. Ended up searching around on that and fixed it with:

sudo rm -rf /var/folders/zz/zy*

Appreciate the tip on the Console app. I didn't know about that and it led me to the answer!

| improve this answer | |
  • I ran into "operation not permitted" on this because they're protected by csrutil stuff. You could disable that, but I didn't have to, I just booted into recovery mode (hold command+r while booting) and was able to run this command from Utilities > Terminal and it worked. – tobek Sep 17 '18 at 3:11
  • This actually helped when simulateously running sudo softwareupdate -i -a in Terminal. I could resume my hung up update process – AirUp Dec 3 '18 at 20:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .