I followed the instructions here https://apple.stackexchange.com/a/312273/72004 to get an FTP server running on High Sierra. But when I log in to localhost, it doesn't recognize me as a user.

% ftp localhost
Trying ::1...
Connected to localhost.
220 ::1 FTP server (tnftpd 20100324) ready.
Name (localhost:[my username]): [my username]
530 Login incorrect.
ftp: Login failed

What gives? How can I restore myself as an FTP user? Thanks!

  • Have you tried logging in with the username ftp or anonymous? That seems to work fine for me. I haven't used ftpd very much, but a lot of it seems to depend on your server configuration. Some tutorials for BSD & Linux are helpful for this. – GDP2 Apr 24 '18 at 19:42
  • Awesome, thank you. Logging in with a username of "ftp" works. But it fails with what I'm trying to do, which is to update a local WordPress installation via FTP. And maybe I should rephrase my question. – Richard Maneuv Apr 25 '18 at 18:48
  • Hmm, yes, rephrasing your question would probably help so that people can get a better idea of exactly what you need. – GDP2 Apr 25 '18 at 19:31

I finally solved my problem.

#set file ownership so we can update WP
sudo dseditgroup -o edit -a <your username> -t user _www
sudo chown -R _www:_www <path_to_wordpress>
sudo chmod -R g+w <path_to_wordpress>

sudo chmod 777 .htaccess
sudo chmod 755 <path_to_wordpress>/wp-content/uploads

Hope this helps someone else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .