7

My iPhone Wi-Fi hotspot (first one in the screenshot) is shown with a different icon from any other hotspots (Android, broadband etc).

enter image description here

This doesn't bother me except I need to manually re-connect my Mac to the hotspot whenever it's restarted/woke up from sleep, instead of it auto-connecting like other Wi-Fi hotspots.

Anyway to get my Mac to auto-reconnect?

Specs:

iPhone 6 iOS running iOS 11.2
MacBook Pro running macOS Sierra

  • 1
    Same appleId on both devices? If so, you shouldn’t need to connect. – Tyson Apr 19 '18 at 2:02
3

Go to Sytem Preferences>Network>Wi-Fi>Advanced>Wi-Fi and drag the item with hotspot name to the top. This will prioritize that Wifi network over any other network.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .