I am trying to update a jailbroken iPhone 4 IOS 4.3 to IOS 5.0. I have acquired the needed things from this link http://www.jailbreaknation.com/jailbreak-ios-5-5.0-on-iphone-4-ipod-touch-ipad-with-redsn0w. First, I got the error 3194 when when itunes was trying to verify the .ipsw file with apple. I fixed the problem by downloading TinyUmbrella and turning on the TSS server. But now I get a 1604 error when itunes trys to prepare the iPhone for restore. I sort of fixed that buy putting the iPhone into Pwned DFU mode using IREB or Redsnow 0.9.9b8. Now I'm getting error 1600. How do I fix this?

Extra Info: Itunes version: 10.2 Yes I have tried normal DFU mode and Recovery Mode.

Thanks In Advance.

5 Answers 5


You can't update your phone to iOS 5.0 Not even if you have your SHSH saved. So nothing you do will allow you to install 5.0 right now. At least for the time being. Your only option is 5.01. The problem is that apple is no longer signing 5.0 and no shsh blobs will help you neither because a new security measure implemented on all 5.X

So if you need an unlock in order to use your phone I would highly recommend not updating to 5.01 because UltraSnow is currently not working on 5.01 despite of what baseband you have. No even with 1.59 baseband (but this is just until ultrasnow is updated to work on 5.01) If you don't need an unlock then you can safely update to 5.01 and do a tethered jailbreak using the latest redsn0w and pointing the ispw to 5.0

And before doing anything please update to the latest iTunes.

I hope this helps.

  • Damn, so the ispw that I dloaded for 5.0 is useless now? Do I have to press the upgrade or do I need a custom ispw? Commented Nov 27, 2011 at 15:11
  • But according to this video, upgrading to IOS 5.0.1 could result in the inability to unteather the jailbreak later. youtube.com/watch?v=8dPkEx-uxY4 Commented Nov 27, 2011 at 19:50
  • Yay, it worked! Commented Nov 28, 2011 at 12:20

I was having same problem while updating iPhone 4 from 4.3.3 to iOS 5.0 and then i got the solution. Updated my itunes but updating to ios 5.0 was not possible as apple is not signing 5.0 so i downloaded ios 5.0.1 and use sn0wbreeze to build custom ipsw put my iPhone in dfu mode and shift restore my iphone through itunes. Bingo i was updated on i0s 5.0.1 with preserving baseband and then i used gevey ultra sim for unlock. Hope this helps.

  • I will try that as soon as I dload ios 5.1 Thanks. Commented Nov 27, 2011 at 19:14

You need to edit your hosts file and remove all the references to the Apple server. Then start the update from PWND mode... except you're not updating, you're restoring the phone. Let me know what it does...

  • So you mean I should remove this line from the hosts file? gs.apple.com Commented Nov 27, 2011 at 14:45

I'm not sure, but it seems like your iTunes version is way out of date. Try updating to 10.5 or 10.5.1 and see if you have any luck.

  • Thanks, I will try that now. I knew that advertising would work! Commented Nov 27, 2011 at 14:09

This should fix your problem:

This should get fixed soon anyways here is the solution for you.

  • Download TinyUmbrella
  • Launch it.
  • Click on the “Advanced” tab.
  • Uncheck “Set Hosts to Cydia on Exit”
  • Click on “Apply Changes”
  • Reboot your PC/Mac.
  • Now Connect your iDevice to the computer and hold the Shift Key and Click on Restore in iTunes and browse for the IPSW file you downloaded.

If you are a non-jailbreak user or If this doesn’t help then try another solution

  • Exit iTunes
  • Locate your hosts file (/etc/hosts or c:\windows\system32\drivers\etc\hosts)
  • Open the hosts file with Administrator privileges using Notepad.
  • Add the following lines to the very bottom of the hosts file: gs.apple.com

  • Connect your device to the computer

  • Launch iTunes
  • Put device into DFU Mode by turning your device off and then holding down the sleep and power button for 10 seconds, then release the power button but hold onto the home button until iTunes tells you that the device is now in recover mode
  • Use the iTunes Restore feature as usual with the iOS device

If you want you can remove the gs.apple.com line from your hosts file again so that iTunes can properly update as usual.

  • 2
    Welcome to Ask Different! You've posted this as an answer, which is only for things that directly answer the question asked. Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. Please take a look at the FAQs for more info. Thanks. Commented Nov 27, 2011 at 17:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .