1

I have two computers (iMac, MacBook Pro). I am the sole user of both, and I am logged into the same iCloud account on both. Both run High Sierra.

I used to be able to connect from MacBook to iMac via AFP either by clicking the iMac in Finder's sidebar or doing Command+K, afp://username@imac.local/ — and then either way authenticating with my local-to-iMac credentials.

On High Sierra, the MacBook connects automatically using my iCloud ID instead, and then I have no access to anything. If I click "Disconnect", it immediately logs in again with my iCloud ID.

How can I either...

  1. Disable connecting with this iCloud account (without logging out of iCloud on either machine)

or

  1. Grant access for my iCloud account to the directories I want?

This looks like the same question, but the answer doesn't seem to work at all (I've always done username@imac.local and it no longer works).

  • AFP has been deprecated, have you tried SMB? – Allan Apr 16 '18 at 16:45
  • Interesting... I didn't know AFP was deprecated. Trying SMB does seem to work. It still says I'm logged in as my Apple ID, but my privileges match my real account, which is all I really care about. – VoteyDisciple Apr 16 '18 at 18:03

You must log in to answer this question.

Browse other questions tagged .