0

I have followed all the instructions provided at MacBook Pro: How to disable discrete GPU permanently from EFI? and I'm stuck at the following step:

3.1 Move AMD / NVIDIA kext files to a backup directory

Remove all the AMD (or NVIDIA, depending on your card) kext files in the Terminal in Recovery Console. Trying to remove them in Single User just gives sandbox errors, so don’t do it in Single User Mode! (the one that you boot with cmd+s).

  • If you have FileVault, unlock it first.
  • Boot into Recovery (cmd+r) directly. If it fails then repeat step 2 and retry (dGPU could get active again after booting into the os with AMD / NVIDIA kexts).
  • Start Terminal (This commands are for AMD. If you have NVIDIA, change accordingly)

    diskutil cs list (find Logical Volume UUID: last item)
    diskutil coreStorage unlockVolume UUID (UUID: from previous command)
    cd /Volumes/Macintosh\ HD
    mkdir AMD_Kexts
    mv System/Library/Extensions/AMD*.* AMD_Kexts/
    reboot

The Result is: enter image description here

I'm using 2 hard disks, with no partition, a 120 Gb SSD for the system only and a 750 Gb drive for data. I actually don't understand the commands, I'm just following the instructions. After reboot it still hangs halfway.

Please, what should I do next?

Im using macbook pro 17" late 2011 with HD Graphics 3000/ AMD Radeon HD 6770M

0

The problem that you're having is that you're not quite following the instructions correctly.

More specifically, you've run the diskutil cs list command correctly, but the purpose of running this command was to identify the Logical Volume UUID. And, the reason you needed to identify it was because you need to actually use it in the next command.

In other words, instead of entering:

diskutil coreStorage unlockVolume UUID

you need to enter

diskutil coreStorage unlockVolume 3F7CB47E-F743-4DBF-9BF1-10E574F85D13

instead.

NOTE: This answer is designed to clarify how you needed to follow the instructions you're following. As your question only quotes a portion of those instructions, I cannot directly vouch for the accuracy or validity of the full instructions you're trying to follow.

  • i enter diskutil coreStorage unlockVolume 3F7CB47E-F743-4DBF-9BF1-10E574F85D13 the result 3F7CB47E-F743-4DBF-9BF1-10E574F85D13 is not encrypted and its attached as disk3 and i continue with next same commands and the result is the same as the picture and still hang halfway – Dindin M Kartama Apr 16 '18 at 9:02
  • yes, the next command after diskutil coreStorage unlockVolume 3F7CB47E-F743-4DBF-9BF1-10E574F85D13 is not encrypted and its attached as disk3 the rest has the same result as the pict. – Dindin M Kartama Apr 16 '18 at 9:08
  • Okay, well, that tells me you're not using FileVault (i.e. your drive is not encrypted and therefore there is no need for you to run that command). Or, at least the drive that UUID refers to isn't! So you should be able to just skip it - although, now that I'm looking at your screenshot, cd /Volumes/Macintosh\ HD is not going to work in your case because your drive isn't called Macintosh HD, it's called Mindasari HD. What happens if you run cd /Volumes/Mindasari\ HD instead? Also, are you using terminal from Recovery mode? – Monomeeth Apr 16 '18 at 9:17
  • i typed cd /Volumes/Mindasari\ HD, seems to be ok (i assumed ok because no error respond, directly go to next blinking cursor), go to next mkdir command : ok, last command mv has the same result as pict and still hang halfway. Yes im using terminal recovery mode (cmnd + r) But is it correct that detected HD is my 750Gb Data HD instead of my 120Gb system data? – Dindin M Kartama Apr 16 '18 at 9:47
  • Well, what is your system drive? Your screenshot only shows one drive, not two. Instead of using diskutil cs list, try diskutil list instead. Do you then get two drives listed? – Monomeeth Apr 16 '18 at 10:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .