I'm trying to do a first-time install of Windows 10 1709 with Boot Camp Assistant. During installation, I receive the message: "An error occurred while copying the Windows installation files."

This leaves me with the extra partitions, which are cleaned up upon restarting my computer, starting Boot Camp Assistant, and letting BCA reset the partition.

I've tried booting into System Recovery, running csrutil disable, and retry the installation procedure, but I receive the same error.

Hardware: MBP 2017. OS: 10.13.3

  • Since you have disabled System Integrity Protection, you might as well add the output from the commands diskutil list, fdisk /dev/disk0 and gpt -r show /dev/disk0 to your question. These commands will not change your computer. The commands show the contents of the internal drive partition tables. Apr 17 '18 at 11:05

I created a macOS tool to solve the problem and create a new ISO that works. I also wrote up an explanation. It is related max file size of FAT32 and how Boot Camp Assistant prepares the installation.



If you are trying to create a bootable USB using Bootcamp Assistant and then if you get "could not create bootable or error copying Windows file" then it should be that you have MOUNTED the ISO image in Desktop... Unmount it and the error won't appear. This is the method which worked for me after getting the error.


Is your hard drive healthy ?

You can check some usefull software here.

Otherwise it seems it could also be your Windows installation files that are corrupted.

Do you use a DVD, or an ISO on USB KEY created in bootcamp ?

Can you try to format / re-create the USB KEY if so ?

  • The MBP is brand new, I don't think there are any issues with the SSD. I downloaded the windows ISO recently. I have a newer MBP, so it performs installation by copying the ISO to a separate partition, instead copying it to DVD or USB
    – eqzx
    Apr 16 '18 at 19:23
  • @eqzx Even if you downloaded the ISO recently, it could still be coreupted
    – user255044
    Apr 18 '18 at 18:38
  • Is it possible to try with USB DRIVE ?
    – Chris
    Apr 18 '18 at 18:42
  • @Chris I'm not sure... Bootcamp didn't give me the option
    – eqzx
    Apr 20 '18 at 19:07
  • @eqzx Mmh, sorry so I don’t know
    – Chris
    Apr 20 '18 at 19:30

It may be that your internet connection is struggling with the download, and that this software https://github.com/timsutton/brigadier from @timsutton or else this question How to download Bootcamp drivers without Bootcamp assistant? gets you further?


I was able to solve this by using an older release of Windows 10. 1803 wouldn't work and I found a reference to using 1703 due to a FAT32 size issue. My initial attempts to get 1703 working also failed until I realized 1703 July 2017 update was larger (5.1 GB) than the original 1703 release (4.0 GB). Since the issue revolved around the 4 GB limit of FAT32, I tried the original 1703 version and was successful.

Between steps I reset the BootCamp Assistant efforts by rebooting, opening Disk Utility, and deleting the BOOTCAMP partition.


All you guys need to do is very simple ..windows 10 file when you download from microsoft its 5.8 or 5.9 gb but when bootcamp is going to format the disk its automatically making separate file of less then 1 point from the actual file that's why error massage comes back saying unable to fit in the usb or what so ever disk don't waist your time on formatting the disc again and again, hope answered the Question to solve the problem all i did is i downloaded from other site where the file was 4.22 gb and the work is done and i am using mu windows daily ,good luck

  • i even tried with 1tb disk but same error and then i tried to check the problem and found
    – Abbas
    Jan 9 '19 at 22:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .