2

I wish to enable Text Message Forwarding to send and receive SMS from my MacBook Pro (running macOS High Sierra 10.13.4). I remember having used this feature for a while with both iOS 10 and iOS 11 on my iPhone. However, when I try to enable it now, I can no longer see the option available under Settings app → Messages (I'm running iOS 11.3). It used to be available previously. I have only one Apple ID which I use for everything. I am logged in with it on both my MacBook Pro and my iPhone.

Is this feature removed in iOS 11.3? I remember using it after upgrading to iOS 11. I don't recall this option requiring some other setting to be enabled in iPhone. Here's the screenshot from the Messages setting. The Text Message Forwarding option is clearly missing:

How do I resolve this issue? As I compare the screenshot from my iPhone with the one provided in the Apple knowledge base article, it appears that Show Contact Photos toggle is missing too. Are these official/documented changes in the Messages app?

  • It's not removed for sure. I would suggest turning off and on the iMessage on your mac (Messages -> Preferences -> Accounts -> Enable this account). – mspasov Apr 15 '18 at 19:34
  • @mspasov Tried doing it on both iPhone and Mac. No change. – Nimesh Neema Apr 15 '18 at 19:36
  • 1
    @mspasov Apparently, the option is available now. It appears that it takes some time between toggling iMessage on Mac and having the Text Message Forwarding option show up in iPhone. – Nimesh Neema Apr 15 '18 at 19:47
1

Turn off iMessage on your Mac by going to Messages → Preferences → Accounts → Enable this account and turn it on again.

Now restart your iPhone and the option will show up.

1

For iPad users, I was able to make text forwarding re-appear by checking off my phone number in iMessage.

  1. On your iPad, open Settings -> Messages -> Send & Recieve.
  2. Make sure your phone number is checked.
  3. Reboot your iPhone

The message forwarding option should now be available

Credit to HankAZ and lv1 on iMore’s forums for this method.

0

To add to the other answers… Another reason Text Message Forwarding may not show up, is that you simply need to activate your Apple ID email address for use with iMessage. Even if it was enabled previously, it's worth checking this again, because it's a very simple fix if this is all it is.

  1. Open Settings > Messages > Send & Receive.
  2. If your Apple ID email address is not listed, look for a button that says 'Use your Apple ID for iMessage' and tap it.
  3. When your email address appears, confirm that it is checked.
  4. Confirm that the 'Text Message Forwarding' option is now visible. If not, refresh the screen by going back to the main Settings screen, and then back into Settings > Messages.
  5. At this stage, your other devices may ask you if you want to use your phone number in Messages. If not, activate them under Settings > Messages > Text Message Forwarding.

You must log in to answer this question.

protected by bmike Nov 10 '18 at 19:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .