I have a used iPod Classic 5th Generation (A1136) that was purchased for a parent as it is compatible with all their 40-pin gear. One of the parents already has an identical model which was "working fine" (although hadn't been synced for over a year). By this I understand that syncing has worked on their family PC (running Windows 10) in the past, but updates may have been run / fiddling may have taken place since the last successful sync.

However, I plugged in this newly purchased iPod to the family PC (via USB) and strange things began to happen. The iPod appeared to connect, then disconnect and reconnect again in a loop until eventually Windows gave up and said the device had malfunctioned. iTunes doesn't detect the device at all, but once the connect/reconnect loop gives up the iPod appears as a mass storage device - but iTunes continues to ignore it.

Things I have tried

  • different computer - tried it on another Windows 10 machine with an identical version of iTunes ( - works flawlessly (with the same sync cable)
  • different USB port on the same computer - all behave identically
  • uninstall iTunes, reboot, reinstall iTunes, reboot - same behaviour
  • reinstall Apple Mobile Device Support driver (usbaapl64.inf) - same behaviour

Honestly, I'm tearing my hair out. Short of a clean Windows 10 install I don't know what else to do. Any ideas?

  • 1
    I know the different computer/same cable working seems to eliminate the sync cable, but have you tried a different cable with the same computer?
    – dwightk
    Commented Jan 15, 2019 at 15:33

15 Answers 15


I spoke with Apple Support. The iPod Classic is no longer supported by the software, period. Backwards compatibility is not considered and old versions of iTunes are not provided by Apple. In fact, the support personnel are forbidden to provide an older version. They suggest buying a new iPod.

  • Did they happen to show you the official page saying which iDevices a given version of iTunes support? Commented Mar 11, 2019 at 6:16
  • That's pretty crazy
    – Fiksdal
    Commented Nov 9, 2019 at 13:29
  • That is strange, on support.apple.com/nl_NL/downloads/itunes I see a link to download iTunes 12.4.3. One answer below mentions this was dropped in 12.9, so that version should help you (and me once I tyr). but there's someone else below that got it working with 12.10 too, so I'll try a bit of rebooting etc first.
    – Legolas
    Commented Jan 18, 2020 at 22:53
  • I followed support.apple.com/en-us/HT204095 and got my old 4th Gen iPod working on Windows 10 64-bit with iTunes
    – Legolas
    Commented Jan 18, 2020 at 23:05

The older iPods are no longer supported by the new iTunes 12.9. To get the iPod back on track, it's best to install an old version of iTunes on a Windows PC. To get the older versions of iTunes, search in Google.

  • I've managed to find itunes v8 and use my ipod, thanks. Commented Jun 25, 2020 at 1:00

I had this problem and tried everything from all kinds of forums and posts. Although my iPod was registered and visible on one of my computers, it was invisible and did not appear in iTunes on another until I assigned a drive letter to it in: Control Panel\Administrative Tools\Computer Management\Disk Management - and suddenly there it was!


I feel your pain! I have an iPod Classic 160GB that is suffering the same issue on my Windows 10 PC and tablet as of a couple of weeks ago. However, my iPhone 8 is working perfectly.

Like you, I have followed all the suggestions I can find on the web, including restoring my PC from a month ago and then installing an older version of iTunes with no luck.

Windows currently recognizes the iPod as a USB disk, even when I switch it out of disk mode. When I go through Device Manager to update the driver under Portable Devices to install the same driver as the iPhone is using, it tells me that it is not a valid driver for that hardware. So Windows PnP does not recognize it as a iPod, which is a software issue? So why didn't the recovery work?

I have run all sorts of diagnostics on the iPod with no issues. I have reached the stage where it realizes that it is corrupt, and even tells me to restore it using iTunes, but if Windows doesn't recognize it... I have noticed that Windows hangs when it is attached, and I have had timeouts on the driver install.

I'm planning to go into my local Apple store next week, but I wonder if even their Geniuses understand Windows drivers and PnP. I also plan to hammer it this weekend, since it should be a user solution. I will post any updates.

Slight update: OK, so Windows 10 PnP returns a Device Identification String which it matches to a device in the "Models" section of the INF file. So these must not match! Now the INF file is from the latest Apple drivers, so is the iPod screwed enough to be returning a DIS that matches to a USB device but not an iPod? Going to look at resertting the iPod a few more times.

  • Let's work on the question and not blame the answer here. This question begs the answer I'll add in a bit. Allan. I'll +1 this answer since Geordie is clearly trying to help and move the topic forward with solutions and data and suggestions.
    – bmike
    Commented May 5, 2018 at 16:37

I did take the cable and ipod to a friend with a Mac and got nowhere.

However, I went to my local Apple store on the way home. They attached to one of their laptop and iTunes recognized it almost immediately as needing recovery. When it was done, I connected it to my tablet, where iTunes recognized it as an Apple formatted iPod and allowed me to reformat and populate.

The problem appeared to be corrupted firmware returning a string to PnP that was not recognized. You need to connect it to a Mac, and good luck!

Thank you and goodbye!

  • Thanks for this answer - I will bear it in mind and try the other solution suggested too - will update on progress when there is some (which may take a few weeks)
    – stefandz
    Commented May 6, 2018 at 18:25

I have a newish Win 10 64 bit that has never had iTunes on it. I downloaded iTunes 9.2.1, ran setup and plugged in the iPod. I got an error message telling me to unplug it and then plug it back in. I did and it worked. I've put 1 new song onto the iPod so far and it worked just fine. Here's a link to the page for 9.2.1: https://support.apple.com/kb/DL1056?locale=en_US


Something strange is going on... I have a 5th gen iPod, now called classic (no such tag when purchased), 80 GB, software version 1.1.2 and it works fine with iTunes version running on Windows 10 Home 64-bit version 1903 OS build 18362.418, and has never stopped working through all the iTunes and Windows upgrades/changes since iPod was bought more than a decade ago. Since the original question states that it worked flawlessly on another computer, it makes me think there may be a software version issue; make sure your CPU, OS, and iTunes are all either 32-bit or all 64-bit. While 64-bit CPUs can use 32-bit OS & software, things tend to work better when they all are 64-bit, and 32-bit CPU can only use 32-bit OS and software. If that is all good, try different USB ports & cables, since both go bad.


Using a 3rd part music manager is the only thing that is really going to help. iPod classic support is killed off in recent iTunes on mac and win so you need a 3rd party app to do so, unless you're still running a few versions back iTunes app. I use "transpod" to add and delete music that gets me by.

  • Given that Apple stopped supporting these old iPods, I think relying on custom solutions to recover the control of our devices is the way to go. Sadly transpod is somewhat hard to find and license based. Is there any freeware alternative?
    – Vichoko
    Commented Jun 17, 2022 at 1:58

Take the device and cable to another iTunes and you'll know very quickly if the device or cable is flakey or you need to dig into the computer as the cause of the instability.

On windows, dozens of things need to line up for iPods and iPhones and iPads to work with iTunes so you would need to be very systematic and work through all those things:

Good luck and once you have a repeatable error condition in iTunes, please ask a follow on question with those specific and repeatable errors for more help.

  • Thanks for this. As I note in the original question, using the same device and cable with a different machine work flawlessly, so the issue is definitely with the computer itself. Initially this problem went away “on its own” but is now back. I am not going to be at the parent in question’s machine for a few weeks but will go through the detailed troubleshooting thread when I am there. Thanks for your pointers - I will update when I have more info.
    – stefandz
    Commented May 6, 2018 at 18:20
  • @stefandz My apologies - I totally missed you had already taken it elsewhere to rule out device and cable. Best of luck with the windows half - it's quite a lot of work sometimes - I hope you find a speedy culprit like a missing driver or anti virus that blocks the connection.
    – bmike
    Commented May 6, 2018 at 18:25
  • I followed support.apple.com/en-us/HT204095 and got my old 4th Gen iPod working on Windows 10 64-bit with iTunes
    – Legolas
    Commented Jan 18, 2020 at 23:04

I have received this link where you can find all the old version from iTunes.


I have the same problem as you mentioned, but without a solution at the moment. I am from Nicaragua and unfortunately here we do not have Genius from Apple: there is just one Apple center and before yesterday I called and they do not give technical services for the iPod classic 160 Version A1238.

I am desperate I need to recover my ipod.

Help please.


What about using MediaMonkey to update/see your iPod? I did this... i upgraded iTunes... 12.9.5, plugged in my old 160GB iPod.. no show... so I installed MMonkey, and happy now :) And removed iTunes of course...


I had similar problems where itunes wasn't detecting my 1G ipod touch, however I just downloaded the latest version of itunes (itunes just to see what happens and to my surprise, it detected my 1st generation ipod touch. I think Apple fixed the issue.

  • iPod Touch != iPod Classic, but updating could be a useful fix.
    – JMY1000
    Commented Jan 23, 2020 at 4:29

You have to uninstall iPod Support, open iTunen then connect the iPod. iTunes will asked for install iPod Support, click yes. The iPod will be displayed on the devices menu.

If this doesn't work delete the folder iPod under "HKEY_LOCAL_MACHINE/SOFTWARE/Apple Computer, Inc./" then try again the previus steps.

Tested with iPod classic on windows 10 with iTunes


I have a 5th gen iPod which my Windows 10 computer quit recognizing. I tried all of the troubleshooting I could find on the internet and finally replaced the battery. And guess what? The latest version of iTunes on my computer recognizes it.

  • Can you confirm that you are talking about a 5th gen iPod classic here (as asked in the question), and not an iPod touch? Also, please add the iTunes version number, "latest" will change over time.
    – nohillside
    Commented Aug 9, 2019 at 7:28

ALL iPods still work on any version of iTunes. Even the Original 5GB 1st Gen works. They even work on Catalina in the Music app

  • Yes, this is technically correct and how it's supposed to work. However, how does this contribute to solving the OP's problem that it's not working like it should?
    – Allan
    Commented Jun 16, 2020 at 21:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .