2

I have an Early 2011 MacBook Pro (A1286). I upgraded it to macOS High Sierra and I sold it to a friend of mine, who returned it back after few weeks because it stopped booting. It always gets stuck at white screen after the loading bar reached certain level, no matter what booting method we tried - safe mode, recovery, recovery from the Internet.

After few days of several attempts, I had a bad idea of downgrading firmware by using the Firmware Restoration CD 1.9 which was probably not intended to be used with the particular model. At first, the CD did not do anything during booting but I forgot it in the DVD drive. However later during one of reboots, the laptop beeped and probably installed the firmware. Since then, the keyboard does not work and of course, it still does not boot.

Is there any way, how to repair it and install the correct firmware?

UPDATE:

This is probably not related to firmware but some hardware error. I removed the hard drive and installed Sierra on it from different Mac. It still hangs with a white screen.

UPDATE 2: USBs seem to be dead as well. External keyboard does not work and even the LED indicators do not switch on. The same for infrared mouse which does not light on. Arduino works gets power from the port. Nothing from the USB boots even though it did before.

I also tried a hard drive with Ubuntu which booted before. The screen goes black and stays like that.

I haven't tried CD/DVD as I don't have an option how to eject it then. I even had a problem to remove the Firmware Restoration CD. I had to use a very brute force to get it out.

UPDATE 3 (as of 2018-05-03): I have tried to boot latest Ubuntu from DVD. The system probably booted as the DVD device was working for several minutes. This time, all I could see was just a black screen. A GPU issue? But I don't know why the keyboard is not working :-/

UPDATE 4: An Apple service identified a hardware problem on a main board, which would need a replacement. Thank you all for your advices.

  • Have you tried to boot in Verbose Mode? Hold Cmd-V while turning on. Also, when it "beeped" what did it sound like. A single beep, multiple beeps? I wouldn't worry about Firmware restoration at this point, if the firmware is not for your model, it won't install. – Allan Apr 15 '18 at 13:11
  • As I mentioned above, the keyboard is not working. It does not react on anything I do. USB keyboard does not seem to work. I heard several beeps but I don't remember all the details – Jarda da TomeCzech Apr 15 '18 at 18:35
  • If a firmware is being installed, a quite distinctive long beep is heard and y should see a progress bar. How do you know the kbd isn't working? (Have you tried verbose boot, safe boot, changing boot volumes (opt), smc reset?). – How did you "install" Sierra? (replaced the drive or really ran the installer/cloned the installation)? – LangLangC Apr 20 '18 at 11:44
  • The keyboard does not work at all. Eject button, shortcuts, nothing... USB ports are dead as well. I haven't seen any progress bar, but even the boot sequence is different/shorter than before these beeps. What I tried was to a) install Sierra on different machine and replace the drive and b) copy the installer (using the "Install MacOS Sierra" app) and try to finish it on the broken machine. In a) the OS does not boot, in b) the installer does not start. – Jarda da TomeCzech Apr 20 '18 at 13:25
  • Strange beast. Have you tried booting without internal HDD (from USB, Thunderbolt or optical drive)? How do you know USB is dead, just from the keyboard? [Hint: Try not to answer here in comments but update your question with edit. That also bumps up the Q for more eyes] – LangLangC Apr 20 '18 at 17:14

You must log in to answer this question.

Browse other questions tagged .