2

Here's the problem that I have

  • My Bluetooth headset is connected to my smartphone and laptop.
  • I'm listening to music using the smartphone.
  • When I do some invalid action using the laptop my music gets interrupted.

I know how to volume down not to make a sound effect for an invalid action but what I want is to completely disable the sound effect so that my Bluetooth headset is not interrupted by it.

How can I completely disable the sound effect?

FYI, these threads don't have the answer

Update

  • I still want to listen to the sound of my laptop when it plays videos or something. I want to disable only the sound of an invalid input.
  • Even if I set the alert volume to zero my music still get interrupted by the sound effect of an invalid action - the sound effect doesn't make any sound but my music stops for some seconds as my laptop plays a sound effect without a sound.

So I want to know the way to completely disable the sound effect of an invalid input, not the way of muting it.

  • I'd already added my answer before looking at the links... which I now see are exactly the same. Why does this method not work for you? – Tetsujin Apr 14 '18 at 13:45
  • @Tetsujin Thanks for the answer. I want to listen to the sound of some videoes or something from my laptop that's why I have my headset connected to my laptop and smartphone at the same time. And that's why I want to disable only the sound effect of an invalid action. Also, I don't want to choose Internal Speakers manually whenever I connect my headset. – Sanghyun Lee Apr 14 '18 at 14:09
  • That doesn't really seem to explain why the existing answers [or my identical answer] don't work. – Tetsujin Apr 14 '18 at 14:12
  • I've added more explanation. Hope it clarified my question. – Sanghyun Lee Apr 14 '18 at 14:25
  • I have no idea why an alert sound either turned down or sent to a completely different output would interrupt your audio playback. I've been sending audio & alerts to separate outputs for a decade & never seen that issue. – Tetsujin Apr 14 '18 at 14:27
3

You can set alerts to a different output, i.e. Internal Speakers, and/or turn the Alert volume: down completely.

System Preferences > Sound > Sound Effects

Sound Effects Tab

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .