3

The ONLY time it's booted since it's been in my possession was when it was in the Apple Store, when it ran the Apple Diagnostics.

What I've tried is:

  • resetting the SMC (no reaction)
  • using power on pads, which makes the MagSafe turn green for 2 seconds, and back to amber.
  • unplugging the battery and plugging it back in
  • plugging the MagSafe while battery is unplugged
  • unplugging keyboard from macbook and power on pads

Regardless of what I try, when I plug it in, it does the same thing. Fans won't spin up, and when I leave the MagSafe plugged in for about 10 minutes, it's noticeable that heat is coming from the part where the MagSafe usually is.

I don't want to throw it out and get a new one, I really want to get this one working, since new MacBooks are too expensive.

Any suggestions?

  • From your description of things that aren’t working, I’d say that this MBP has serious hardware problems that can’t really be diagnosed remotely. Good luck. – IconDaemon Apr 14 '18 at 8:03
  • Welcome to Ask Different! :) Could you edit your question to add what actually does happen when you try to boot up? For example, is anything displayed on the screen? Do you hear a startup chime? Anything else? – Monomeeth Apr 14 '18 at 8:03
  • Nothing shows on screen, nothing chimes, nothing seems to boot up at all. I've considered getting a new MagSafe port, if that's even possible. – marchkarcz Apr 14 '18 at 8:23
  • Have you tried another power adapter? When it booted in the Apple Store, were they using your power or theirs? Did they have to mess with it to get it to boot, or did they hit the power button and magically it booted? Also this model does have a separate, replaceable DC-In board. That would be the one and really only thing to try, as everything else is logic board. ifixit.com/Guide/… – l008com Apr 14 '18 at 8:35
  • They were using their power supply. I've tried alot of power supplies with this macbook, including some other peoples who worked with their laptops (60 watts, which is what this one uses). They just opened the computer, and it booted. (Yes, it was plugged in). And thanks, I'll try replacing the MagSafe board. – marchkarcz Apr 14 '18 at 8:41
1

Good news, after a couple of months I FINALLY figured out the problem. After watching a Louis Rossmann video, I saw something about jtag connectors. I removed the jtag connector and the fans now spin. Along with that, it says the battery is low on the screen.

I'm assuming something at apple was able to turn it on. But now without the jtag connector it actually is working.

  • 2
    Can you enlighten the rest of us, wtf is a jtag connector, where was it, and how did you remove it? – l008com Jun 9 '18 at 0:23
  • Sorry for such a late response. The jtag connector is something I believe is used for debugging. On this specific model, it's right here: i.imgur.com/JSU8SfN.png. I just used a small knife and sawed it off carefully. I think most people use heatguns to take it off, but I didn't have one. – marchkarcz Jun 11 '18 at 9:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .