5

I have been researching this problem for two days, and I know there are many other posts about it. But the solutions are always "fix the permissions". That does not solve it for me. I have recursively changed the permissions on the symbolic and original directory trees to 777 and I still get the error. Not only is the PID file not being updated, but the error file is not being written either, though the error message in Terminal when I try to start MySQL says that it is. That does suggest something is preventing processes from writing to the directory, but it's not file permissions.

Here's the full error message:

Starting MySQL .Logging to '/usr/local/mysql/data/Sheryls-MacBook-Pro.local.err'. /usr/local/mysql/bin/mysqld_safe: line 198: 11197 Trace/BPT trap: 5 nohup /usr/local/mysql/bin/mysqld --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data --plugin-dir=/usr/local/mysql/lib/plugin --user=mysql --log-error=Sheryls-MacBook-Pro.local.err --pid-file=/usr/local/mysql/data/Sheryls-MacBook-Pro.local.pid < /dev/null > /dev/null 2>&1 ERROR! The server quit without updating PID file (/usr/local/mysql/data/Sheryls-MacBook-Pro.local.pid).

Also, here are my permissions, so you can see this is not the problem:

Sheryls-MacBook-Pro:mysql Sheryl$ ls -laF
total 48
drwxrwxrwx  13 root    wheel     442 Apr 13 14:48 ./
drwxr-xr-x   9 root    wheel     306 Apr 13 14:48 ../
-rwxrwxrwx   1 root    wheel   17987 Dec 27 22:46 COPYING*
-rwxrwxrwx   1 root    wheel    2478 Dec 27 22:46 README*
drwxrwxrwx  40 root    wheel    1360 Jan 24 08:41 bin/
drwxrwxrwx   6 _mysql  _mysql    204 Apr 13 14:48 data/
drwxrwxrwx   5 root    wheel     170 Jan 24 08:41 docs/
drwxrwxrwx  50 root    wheel    1700 Jan 24 08:41 include/
drwxrwxrwx   2 _mysql  _mysql     68 Apr 13 14:48 keyring/
drwxrwxrwx  11 root    wheel     374 Apr 13 14:48 lib/
drwxrwxrwx   4 root    wheel     136 Jan 24 08:41 man/
drwxrwxrwx  39 root    wheel    1326 Jan 24 08:41 share/
drwxrwxrwx   6 root    wheel     204 Jan 24 08:41 support-files/

I'm running MacOS 10.11.6 (El Capitan). Apache is enabled and working, and PHP is enabled and working. Both are the versions that came pre-installed. MySQL is v5.7.21. I've removed and reinstalled it 3 times now. This version does not come with a configuration file.

Should I try an older version of MySQL??

Does anyone have an answer to this problem?

  • To clarify, there is no PID file at all - it's not there. – permutations Apr 13 '18 at 20:36
  • Should the title read “Can’t start MySQL”? – IconDaemon Apr 13 '18 at 22:07
  • There are so many reports of this all over the internet that I think it may be a MySQL bug. It's been reported. bugs.mysql.com/bug.php?id=41067 – permutations Apr 13 '18 at 22:21
  • I got it to write the error log and looked inside. I found something strange: "dyld: lazy symbol binding failed: Symbol not found: _clock_gettime". Huh?? – permutations Apr 13 '18 at 22:57
  • That's it. It's my Mac version. I didn't want to update it because it would break Dreamweaver CS6, and I paid too much for that. github.com/pocoproject/poco/issues/1453 – permutations Apr 13 '18 at 23:00
4

I solved it! When I finally got it to write an error log (needed to fix the permissions for that) and looked inside the error log, I saw it was missing the symbol _clock_gettime(). When I googled that, I discovered MacOS didn't add that symbol until OSX 10.12, and I'm running 10.11 (so as not to break Dreamweaver CS6).

I uninstalled MySQL 5.7.21 and looked for the latest version of MySQL that supported El Capitan (10.11), which turned out to be 5.7.16. I installed that, and now it's running fine.

  • Where did you find 5.7.16 for mac? I can't find it anywhere! – Agent Zebra Jan 4 at 23:59
  • 1
    As I recall, it was on the main MySQL site. There is an area for older versions. You have to hunt around a bit to find it. – permutations Jan 7 at 14:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .