I changed some of my Macbook's security settings today. I also updated to the latest version of High Sierra (10.13.4) shortly before changing my security settings. Shortly thereafter, I got the following message from McAfee:

Your system's security preferences are blocking McAfee software from loading. Because of this, some software features are not enabled. You can change your settings in the Security & Privacy System Preferences pane. Click OK to open System Preferences.

"Cancel" and "OK" are then given as options.

This keeps popping up.

The privacy features I changed:

  • Share Mac Analytics and Share with App Developers were turned off.
  • Dropbox and Steam are no longer allowed to "control [my] computer", changed under "Accessibility"
  • Under Location Services, under System Services, "Location-Based Suggestions" was turned off and "Significant Locations" was reset and turned off.

What security features are making McAfee upset? Or does it have to do with the OS update?

1 Answer 1


When the message from McAfee appears, click OK and open System Preferences > Security & Privacy. Under the General tab, you may see an Allow button like the image below. You will need to click this and follow the prompts to allow your software to work properly.

McAfee's knowledge base has instructions on this under the "Standalone installation on macOS High Sierra without a Mobile Device Management (MDM) profile" section of this page.enter image description hereThis is a security feature introduced in macOS 10.13 to make sure certain kinds of software, kernel extensions, are loaded with the permission of the user. This Allow button is only available for 30 minutes after the alert appears.

  • 1
    This is happening on Big Sur, surprisingly no bloeck message is there in Security & Privacy, hence, no allow button Jan 21, 2021 at 8:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .