2

I'm trying to reinstall Mac OS on a late 2009 21.5 inch iMac. The previous owner tried to install ubuntu on it but failed to get it to work properly so I'm trying to install Mac OS Sierra from a USB stick. I know the USB works because I can boot from it on my Macbook Pro. The problem is that I can't figure out how to get the iMac to boot from the stick. Whenever I try to get into startup manager all I get is an all white screen and a mouse curser. I can get into Ubuntu safe mode and grub but I'm not sure what I can do from there to make the mac boot from USB.

  • I was going to suggest Internet Recovery but I don't think that model had that (Command-R at startup). How good are you with Ubuntu? There may be a way to image the USB key to a DVD, I wish I knew how, sorry. Perhaps a Linux guy could chime in and either call me an idiot or tell you how... But if you can download Sierra on a friend's mac and burn it to a DVD, you should be able to boot from that holding down the "C" or "D" key. – Steve Chambers Apr 11 '18 at 20:31
  • What keyboard shortcut are you using to get into the startup manager? – Volsk Apr 11 '18 at 20:33
  • Are you holding Option while booting? – Allan Apr 11 '18 at 20:35
  • The first iMac with Internet recover is the Mid 2011, so you're right, that's not an option. Not sure why your USB isn't working, but it is possible there is an ubuntu bootloader in the way. The drive should show up if you boot with the option key held down. – lbutlr Apr 11 '18 at 22:19
  • @Allan I was holding down option/alt while booting, but that only took me into grub. I followed Tony's advice and reset the NVRAM and I was able to get into the installer. – BookOwl Apr 12 '18 at 13:36
2

I'm assuming that holding down the option key when starting up does not show the boot drive selector displaying at least your internal drive. If this is the case then there is another bootloader getting in the way.

Your next step should be to reset the NVRAM. You can find instructions here.

  • This worked! Now I just have to figure out how to reformat the internal hard drive so I can install High Sierra (I decided to make a new key with the latest OS), but that's another question. – BookOwl Apr 12 '18 at 13:38
1

The Mac probably has rEFIt installed, or it was uninstalled improperly. Try booting the computer off an original DVD and setting the startup disk. Or try booting with the option key and selecting your installer USB stick.

  • Unfortunately I don't have access to an original disk, so I can't follow this advice. – BookOwl Apr 12 '18 at 13:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .