I recently followed the instructions here to mount an Apple-formatted HFS external drive on Ubuntu. I transferred the files I needed, then unmounted the drive. Now the drive won't mount in OSX. In Disk Utility, the volume (top level) and partition (bottom level) for the external hard drive show up, but the partition will not mount. First Aid on the top level completes without error, but running First Aid on the partition level fails.

What could be preventing me from mounting the drive after following those instructions?

Any help would be greatly appreciated!

$ diskutil verifyVolume disk2s2
Started file system verification on disk2s2 WD My Passport
Verifying file system
Volume is already unmounted
Performing fsck_hfs -fn -x /dev/rdisk2s2
File system check exit code is 8
Restoring the original state found as unmounted
Error: -69845: File system verify or repair failed
Underlying error: 8: Exec format error
  • On my Mac, I tried sudo fsck_hfs -fy /dev/rdisk2s2 which returned ** /dev/rdisk2s2 (NO WRITE); Can't open /dev/rdisk2s2: Resource busy. Attempting to mount via DiskUtility or diskutil mountDisk /dev/disk2s2 just hangs. I'm running sudo fsck.hfsplus /dev/sdx# now. – jonathanking Apr 10 '18 at 17:37
  • Oh, yes I did run those commands in an attempt to mount the drive on my Ubuntu machine. – jonathanking Apr 10 '18 at 17:43
  • I've added the output to my post. – jonathanking Apr 10 '18 at 17:47
  • 1
    In German I'd say kaputtrepariert (try to repair something and actually make it worse) by entering the command ... fsck.hfsplus ... in Ubuntu. Try to repair it with Disk Warrior! – klanomath Apr 10 '18 at 17:52

I solved the issue by running sudo fsck.hfsplus /dev/sdx# from my Ubuntu machine. My external drive can now connect to both my Ubunutu and Mac machines.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .